Bug: inventory does not deduct new roast weight

what am i doing wrong??
i have rt 3.xx newst update
i have fw 558

but on rw i does not use the coffee i roast i my storege

plz help

have a nice day

Hey, I’m not sure I fully understand what you issue is. Is it that the roasts you’ve done on Roastime are not showing on Roast World?

I talked to Kohaii and his problem is his beans are not being deducted from his inventory on RW since we changed platform.
Anyone else have this issue?

Thanks! We’re working on getting this fixed

Yes, It’s affected me since November.

Hey guys, we’ve tracked this issue down and manage to get it fixed. On RW this should be working. However, a complete fix also requires a Roastime update. So in the next RT release + RW, this should work okay.

I will write back here when the Roastime update with the fix lands.

thx m8:-)

Derrick,
I have had this problem of Roast World not reducing my inventory of beans after each roast ever since the RT3 and beta RW upgrades.

I upgraded to RT 3.1.0 yesterday, and was hoping this was the fix you mentioned…but roasted 2 batches, used the RT sync button, then later checked RW, but neither bean had been reduced. RW always shows the correct amount that I just roasted, but never subtracts it from the inventory.

The other strange thing is that in “MyBeans,” the inventory is not in alphabetical order, or in chronological order (as to when added into inventory), but seems somewhat random. Is there a plan to allow us to sort the beans by one of these fields?

Thanks to you and Matt. I like the changes that RT 3.1.0 brought.

1 Like

I have the same problem. Roast World shows my recent roasts, and shows the quantity of the beans I roasted. However, the quantity of roasted beans is not subtracted from my bean inventory. I must manually subtract the roasted beans from my inventory. frustrating. I am running RT v. 3.1.7 on Mac OS. All current with versions as far as I know. Been having this problem for some time! Any help?? Thanks, Gerry.

Hi, I thought this issue was fixed already (I worked on a fixed that got it working for me). Sorry for the inconvenience. I will look into this issue and update you on here.

Hi @lanaiguycoffee @wngsprd,

Can you guys provide the steps that you take for adding the green weight to a roast? I asked @tent (another RW/RT developer) to try to recreate this issue but he said that when he did a roast his inventory weights reduced accordingly. Here’s the exact steps he took:

  1. Start with 1KG
  2. Completed a roast and then edited the roast profile’s green weight to 600g
  3. The change was reflected in the bean’s inventory on RW. (He did have to refresh the page though)

Hello, I will tell you about my experience:

If I put the quantity in green BEFORE or DURING roasting, most of the time it reduces the quantity in stock.

But my workflow is different, I write the data on a piece of paper and then I order it in Roast Wold and here the problem begins.

When I roast 5-6 batches or more and edit the roasts AFTER I don’t usually reduce the quantities in stock.

A suggestion for Roast Time:
I usually have a batch control, where I assign a number to each of my roasts (TC1, TC2, etc) It would be great if it could be automatic.

Also add the amount of green coffee easily in Roast Time, the edit box has nothing wrong, but it is annoying to have to add the amount of green coffee while I am following the roasting curve and the edit box use the most of the display.

Greetings :slight_smile:

Hi @miguelszvy,

So if I’m understanding correctly, the issue is on Roast World and it is encountered when the roasts profiles are edited after the roasts are completed?

One more thing, you edit the individual roasts after completing all the batches rather than subtracting the batches total from the inventory?

Thank you for giving a breakdown. This will make it easier to recreate the issue you’re encountering and hopefully we can get it fixed

Hi @derrxb, I edit each roast after every session, writing the weight in green and roasted (from my paper log) currently I do not have many bags of coffee, so my stock control I do it mainly by eye, I don’t touch the stock available in Roast World but I’m observing if the numbers are changing.

I’m sure that if I start to store more coffee I’m going to need that function working properly (I’m sure that somebody needs the function quite urgent already).

I’ve added my bean supply (weights) to RW in advance. Then, in RT, during the time it takes to preheat, I enter in the roast name, select the proper bean and green weight, temp and humidity and save. Then after the roast, using RT, I then add the post-roast weight. That is my process, but it sometimes reduces the bean supply and sometimes it doesn’t. Other times it doesn’t deduct the correct amount that was specified. I always roast the same amount (453.6gm), so I know what to expect when I look at the result. Even though I do this consistently with each roast. I have largely let this problem go because it isn’t my first post, nor other’s first post about this issue and so I just have to manage it outside of the RT/RW system altogether. Honestly, and I don’t mean to be negative, but this should be solid, as it’s not what would appear complicated, outside of having the two places to manage the process (RT and RW) in the first place.

1 Like

Thanks for continuing to pursue this, @derrxb

My process is identical to @bobstrengera5kj as described above, with rare occasions when I don’t have time during the back-to-back preheat to enter the new roast info, and then I enter it all post-roast. I just looked at my last 2 roasts, both done on May 19. One updated correctly and the other did not (I corrected the one that was not automatically updated). I’ll try to monitor this more closely and report.

Interesting… I had to chime in. I did 4 back-to-back roasts on Saturday May 22 and entered the roast info after I was all done. The data looks to be ok on RW for me - although I didn’t exactly check if the “inventory” got deducted correctly.

Mine was mainly newbie error, I picked up last night that there are multiple identical beans in the base inventory and on a couple of roasts I had selected the identical bean which was not in “MY Beans” list. This accounted for all but 2 errors, not sure what happened with those.

Next chance you get, please check to see if the RW inventories got “deducted” correctly. That’s my only real problem.

I just checked… it looks like RW inventories for the roasts I did this past weekend were deducted correctly for me.

I’ll have to say one thing, I wish we can manage inventory in lbs and roast in kg - because SM sends me beans in lbs! :slight_smile: I’m always having to pull out my conversion calculator…

5 Likes