Firmware updated, possibly interrupted (froze), now have a corrupt audio file on startup

I have the same issue, just got my bullet, connected it to the PC for the first time and did a firmware update and now I have a distorted voice saying “The bullet is ready” in a really slow spooky way. I can no longer connect via USB either even after multiple attempts of installing Roastime/Drivers. I seriously hope I can continue roasting without problems in manual mode.

BTW, Anyone that can direct me to how to get my computer to recognize the bullet when plugged in? all I get is " Unknown USB Device (Device Descriptor Request Failed)"

Did the driver install ever finish running successfully? Are you on windows?

Can you join the slack? We have a version in beta right now that may fix your driver install issue if so:

Jumped on the Slack app and also contacted support regarding the distorted sound.
I’ll post an update here if anything pans out.

I’ve done it so not sure what to tell you….

I was happy to learn this forum has temporary and permanent Mute feature for specific topics and users.


Yeah, as an admin I thought I had ignored him for all of us, turned out it was just for me. But now I have silenced him for good.


Ok, lots seems to have happened here since I last posted but to get back on topic;

My solution was manual bootloader and fresh firmware update with roast time 3(see vid.)

This cleared up the distorted voice issue and allowed my computer to recognize the bullet through USB. All is well now.

Hope this helps!


I’ve been down that road several times and not always cuz I had to… just the familiar path.


As I only had access to a PC for the night It seemed like the only surefire way to get back to business…

No luck on my side. Serial 005237. The video says 4 beeps for the bootloader, I only got 3 but the application worked and I was able to download the beta version (602) which made the screech worse. Instead of saying “The Bullet–(screech noise)” it went to “The (screech noise)” I back-rev’d to the release version ( 591) and got back to “The Bullet (screech)”. This leads me to the assumption that a previous version before 591 would get me to “The Bullet is…” and the version before the previous will resolve the issue :slight_smile: (/sarcasm). At any rate, other than the screech, the Bullet seems to be working fine and the other voices are fine. Out of curiosity, is there a site location for previous versions before 591? I’ll email support and report back. Other than that, I may be preaching to the choir, but the Bullet is an excellent roaster, from the thoughtful design to the toolset, which I’ve needed, I’ve been impressed so far and I’ve only done one roast.Thanks for the quality!

I did try the version on Slack (3.3rc5) and that did not work at all. The app was not successful in loading the firmware. Also the Beta tab throws an error.

If I can borrow my friends computer again and he hasn’t deleted the files I can check what version I used.

I am sorry that you got this problem.
We have found the issue and have a fix for the corrupted voice files so it cannot happen again. However, for you to recover them you need to contact [email protected] and they need to schedule a teamviewer session to fix it. I don’t believe an earlier firmware version will help with this.

1 Like

I just updated my firmware to 591 and have the same issue, I ONLY get the static, there’s no comprehensible words. Will there be a fix in a future firmware or is contacting you through email and teamviewer session the only solution?

From what I read if you’re already corrupted then you need to email support so that they can work out a fix. Newest versions of firmware will prevent it happening but can’t restore it.

OK thanks, I’ll go ahead and email them and let folks know what they tell me.

I just had a similar issue -I tried the other methods mentioned above - which wasn’t working with my set up (I use a Mac). Aillio help was fantastic and super fast. The solution that fixed my firmware self caused debacle was to install the RoastTime 2 (previous version) then connect to the roaster and re-install the firmware. It worked! Firmware was updated, I reinstalled RoastTime 3 and re-reinstalled the firmware this time with no USB interruptions. All is well now and roasting again.

1 Like

Hello all. I’ve just updated to 591 then 602. The update seemed to go through fine, but I have a horrible speaker noise and no discernible voice on startup. 602 said it had a fix for this. Can anyone help me resolve this? I’m on Roast Time 3.41 and firmware 602 (beta) now.

No clue why this has happened but the quoted post above by @jacob (Oct 2021) seems to address your issue. I thought a fix was included in fw 602 but… ?? So it appears you will need to contact Aillio Support.


Please contact support for a tool that can fix this.