Roaster unresponsive and no display


After I finished roasting and cooling the roaster today, I thought I’d upgrade the firmware. When I tried to apply the update, I immediately got an error message that the bullet wasn’t connected. The display on the bullet at this point showed PH and the fan was on high at this point. I unplugged the USB cable, restarted the software, etc. without success (even though RoastTime would detect when the USB cable was plugged in), Finally, I unplugged the roaster and plugged it back in. The fan came on but the display remained black. Tried it a few more time including after waiting several long minutes. Same thing.

Any idea what is going on?

ps: A couple of things that I have been happening on the roaster lately. May be unrelated. But I thought I’d mention it in case it isn’t.

For the past several roast sessions, the roaster display would sometimes go crazy (numbers changing all over the place, beeps, etc.) immediately after I charge the beans. Whenever this happened, I’d immediately drop the beans and restart the roast.

Also, today I noticed that the light would sometimes go out when I moved it. The issue seemed to be either at the USB connector or at the cable near the connector. I haven’t tested the lamp on a different USB connector yet.


Have you try to manually restart it?
Here are so instructions:

Manual Bootloader Mode / Firmware Update
How to recover from a failed firmware update on the Bullet R1
In order for you to upload a new firmware you will need to manually enter the bootloader mode. To do so you will need to short circuit two pads on the control PCB (the one with display).
Please read this guide before you start, in order to familiarize yourself with what you need to do:
Make sure AC power is removed. Disconnect the USB cable from the PC
Remove the 3 hex screws from the front of the control panel, and gently remove the cover. You do not need to disconnect the speaker, just let the cover rest on top of the roaster.
Locate the two pads GND and SDA (see picture below/attached). Connect them with a wire / tweezers / multimeter (set to Amps or mA) or another piece of metal making sure only to touch these pads! It might be a good idea to get someone to help you at this point.
While GND & SDA are connected, plug in the AC power, you should hear 4 beeps. You are now in bootloader mode.
Remove the wire between GND and SDA, being very careful not to touch anything else!
Launch RoasTime and connect the USB cable. Update your firmware as before by going to settings menu, then the update tab, choosing the beta firmware 386. The password is:
Once done, unplug AC power + USB and connect it again to make sure it boots correctly. Replace the cover, making sure the speaker wire is above the 4 digit display
Hopefully you can get your bullet back to normal.
Have a good night


Thanks, Julio, I will try that. Does this only work with the beta version of the firmware or can I use the latest stable one?

Also, any chance you could send a link to the picture reference in the instructions?



Other than the unstable Control Panel display you mention, this is generally a repeat of what I went thru a few days ago. What Julio has provided should get you there except for the f/w reference which is out of date for V1.5/V2 Bullets. What I posted is here. The current ‘stable release’ is 533; the current ‘beta’ release is 538. Even of you could find it, I believe f/w 385 won’t work on a V1.5 Bullet. No password is required.

As I recall (making this iffy), RT’s f/w downloader/installer will complain about the Bullet needing to be in OFF mode cuz RT doesn’t allow for the use of the boot loader.

With all that said, the behavior you describe is probably not going to be solved by re-loading f/w. You should probably contact Aillio support and get a Help Ticket started. I suspect they will suggest there may be a loose/intermittent connection somewhere (control panel?) and they can steer you in the right direction. In the extreme they may tell you to send it to Sweet Maria’s (if that’s where you got your Bullet) where Julio can work his magic on it. But this is speculation on my part… Aillio Support (or Sweet Maria’s?) probably needs to tell you how to proceed.



If you got your bullet from Sweet Maria’s please email me at


Thank you Bruce and Julio for the information.