2nd Failed roast

I just finished my 4th roast on Roasttime v2 and experienced my 2nd failed roast. Not happy.

I preheated to 185 and got the dialog that my machine was ready to charge. Not sure if I hit the “OK” button in previous roasts, but this time I didn’t…I just dropped the beans and set P to 7 on the machine. Roasttime appeared to recognize this and switched to the roast screen, but P, F and D were all showing zero and there was no temperatures registering on the graph at all (the roaster was running fine). The milestone buttons appeared to be working, so it wasn’t like the screen was locked up or anything.

I restarted Roastime hoping to start recording again, but it forces you to wait till the roaster is in stop mode to reset.

To avoid ruining the roast I finished the roast blind. As if this wasn’t bad enough, it seemed that the roast was going way too fast, so I look at P on the roaster and it was switched from 7 to 9 when Roasttime was restarted.

Is there something that I did to induce a bug?


1 Like

Having the same problems. Roast time 2 stops recording and showing data during the roast.

What firmware version are you on guys?


Hey guys,

I have been working hard trying to get this issue solved, but am unable to recreate your experience. I am working on some tools to help us debug it for you though.

Thanks for your patience!

its happened to me a few times too on the latest firmware - ive gotten in the habit of forcing through the roast cycle quickly without beans on the first roast of every session to make sure it logs properly after that

I’ve had the same thing happen for at least half a dozen of my roasts. Noticed it most when manually pressing the PRS button to initiate the ‘charge’ stage.

I am on firmware 448.

I just tried to manually step through to the charge state about 6 times and couldn’t recreate it either, however I did notice that when the charge dialog comes up, F P and D all reset to zero in the background. When you advance to roast step, they update to the default settings (at least under expected conditions)


I am on firmware 448 and software win32 2.0.6. Windows 10. One time froze at the end of preheat and the second about 1 minute into the roast.