Added new bean in RoastTime, now RoastTime won't sync [fixed]

Seems I’ve unknowingly dug myself a hole I can’t seem to get out of…

I’m having some issues with my bean summary in-stock column not reflecting the value shown when looking at the bean details, and I’m in the middle of trying to roast a new blend.

Since blends aren’t supported, I tried to get smart about it…

1 - manually adjusted each bean, subtracting the weight going into the blend.
2 - create a new bean, with the total weight of all beans

But I had a problem understanding the UI, and gave up, trying to add the bean in RoastTime - oops!

It added it as “Untitled”, and now when i try to sync RoastTime, I get a forever spinner.

I’ve logged out and back in to my account in both RoastWorld and RoastTime, same thing.
Also, when I launch RoastTime, it opens on the Roast summary page, and the purple line under the headings continuously scans left to right.

I tried downgrading from 3.4.1-rc1 to 3.4.0, then back, but still no change.

Is there a way to completely uninstall RoastTime, remove all hidden underlying files, then reinstall, with some assurance that I won’t lose any data?

Thanks for your suggestions!

1 Like

Hey @3gswish,

Sorry for just getting back to this. So if I understand the issue correctly, adding a bean via RoasTime is not synching correctly with Roast World? I attempted this on my device and the synching happens correctly for me.

I’d like to ask if roasts, recipes, etc can sync correctly? I’ve seen another case where a user’s firewall setting was blocking RT from sending messages to our server online.

Yes, you can manually remove your local files on RT. Be careful though, if the data has not synced to RW yet, it can be lost forever. You can do this by removing this folder on your local computer: C:\Users\<name>\AppData/Roaming/roast-time.

Best regards,

(perhaps zipping that folder into a backup archive somewhere convenient first :slight_smile: )

1 Like

Yeah, I’d also recommend doing this.

Hi Derrick,

No worries, I completely understand the time pressures on a small dev team.

I mentioned in a previous post, and should have mentioned again in this one, that I’m on MacOS Catalina 10.15.7, and RoasTime 3.4.1-rc1.

Thus, the local data files are in /Library/Application Support/roast-time, and config/setting files are in /Library/Application Support/RoasTime, correct?
Any other locations that I should be aware of?

I’ve backed up these 2 folders, and can make them available if you would find it helpful, let me know.

The last roast that I did showed up in RW, so I’m pretty sure sync is working, just not for beans!

What is interesting is that even though my last roast sync’d fine RT->RW, with the date/time of:
2022.03.27 - 8:17:09 PM

the roast-time/sync/lastSyncTime file shows:
“UQuRIvBWz4hE9bVfSKgtIM5yCwN2”: 1648336479269

( Saturday, March 26, 2022 4:14:39.269 PM [GMT-07:00] DST in human form, assuming linux system time format)

Also, in the RT interface, it lists 18 beans (one being the Untitled one I created in RT), but at the bottom of the bean list is says 1-21 of 21.

The …/roast-time/beans directory contains 18 files, matching the 18 shown in RT, RW shows 20 beans.

First attempt:
I deleted the roast-time directory, and restarted RT. It downloaded the /roasts files no problem, but only downloaded 10 /bean files, doesn’t list any bean in the RT beans UI, and at the bottom shows 1-0 of 21.

Second attempt:
I deleted both the …/roast-time and …/RoasTime directories, and restarted RT and logged in. Roasts synced immediately, but nothing in the bean list. …/beans shows the 10 files again (should be the 20 from RW). Clicking the Sync button in the bean display just causes a perpetual spinning, and no change to the ./beans dir.

Third attempt:
Uninstalled RT 3.4.1-rc1, deleted both directories, installed 3.4.0, same results.

So it appears that maybe the bean data in my account is corrupted, and is not being fully sync’d?

I’m not sure how to proceed - if I delete and re-enter all of my beans, will that throw off the bean data in the roasts?

Thanks for the help,

Hey Greg (@3gswish),

Thank you so much for the updates. I will look into your issue (when I get into the office today) and see on how we can get this sorted out. I don’t recommend deleting and re-entering all your beans to try to fix this issue. The fact that the beans exists on Roast World means that it might be something related to the syncing of beans.

If you are roasting and need to link beans to your roasts, I’d recommend doing this on RW in the meantime while we can get it sorted out. In the community there’s an 3.4.1 RC2 version available if you’d like to try that out. Although, it has the same beans code as in 3.4.1 RC1.

I will ping you on here when I have some more information about your issue.


Hi Derrick,

Thanks so much for looking into it. As you suspect, no change with 3.4.0-rc2.

i am able to manually adjust in RW - thanks for that suggestion.


Hey @3gswish,

I found the issue and fixed it!! It seems that it’s a data corruption issue caused by a reference to a non-existent bean. To be a bit more specific, a bean is linked to your inventory though an intermediate record called a container. This container belongs to a user and has a beanId field that is a reference to a bean on Roast World. What happened in this case is that the beanId was set to null (this should almost never happen` and so it was breaking your Beans sync on RT.

Forcing a re-sync on Roast World should sync your beans correctly. Thanks for posting on here. I will do further research to ensure that this was an isolated event.

Best regards,

1 Like

Hi Derrick,

I deleted the RoasTime and roast-time directories first, restarted RoasTime and bam! everything synced immediately!

Thank you again - your quick attention to fixing this, it makes me feel good about going with Aillio :slight_smile:


1 Like

Nice catch, Derrick!

Really grateful for all the software work you all have put in. Hopefully everyone understands the amount of effort to develop and maintain a both multi-platform client app and a cloud service to back it.

1 Like

Hey @3gswish & @sgtbakerrahulne,

I’m happy to hear that everything is working as expected. Thanks again for posting on here. Yep, we’re a pretty small team but we’re doing our best to ensure that everything is working as expected.

Best regards,