Any chance of distro agnostic linux binary?

Looks like for RoastTime 3, Aillio has moved from a AppImage to a deb package. Any chance of an AppImage for this version as well?


I second this request! Fedora user here.

1 Like

I would also like to see an AppImage or Flatpak from Roasttime. :wink:

1 Like

Adding to the request list. Moved to a non-debian based distro. Working through if I can get this set up somehow.

1 Like

To quote Smokey R, I second that emotion!! (I Second That Emotion - YouTube)

1 Like

I also agree as an Arch Linux user, Flatpak would be nice.

1 Like

For anyone following this thread, I was able to use debtap with the beta of v4.1.2 and get it to work. I also had to add udev rules. Steps were as follows:

  1. debtap RoasTime_4.1.2_amd64.deb
  2. sudo pacman -U roastime-4.1.2-1-x86_64.pkg.tar.zst
  3. Plug in the roaster to power and to the computer, do not run roasttime yet.
  4. ls -larth /dev. Look for /dev/ttyACM0
  5. stat /dev/ttyACM0 - look for the gid value. In my case it was uucp
  6. sudo vi /etc/udev/rules.d/99-aillio.rules
  7. Add the following to the file:
    SUBSYSTEM==“usb”, ATTRS{idVendor}==“0483”, ATTRS{idProduct}==“5741”, MODE:="0666
    ", GROUP=“uucp”
    SUBSYSTEM==“usb”, ATTRS{idVendor}==“0483”, ATTRS{idProduct}==“a27e”, MODE:="0666
    ", GROUP=“uucp”
  8. sudo usermod -a -G uucp $USER
  9. sudo udevadm control --reload-rules
  10. Run roastime. When I launched it, it asked me to add some dependencies. I am not sure those worked or did anything. My guess is that they are scripts for debian variants.

In any case, roastime runs and shows that it is online and connected to the roaster. I will update once i have tried to do a roast, which may not be soon.