Bad times during firmware upgrade, tried everything

Hey friends,

I accidentally updated my bullet’s firmware to 602. That update went fine, and I went back to RoasTime to bump back down to stable 591, during which time the roaster lost connectivity and I have not been able to get anything done since.

If I start the roaster with the jumper for manual boot loader, I get 3 beeps and full fan. No display and no connectivity. If I start the roaster with no jump, 6 beeps, no display and full fan.

I’m running software 3.3.2 on Mac OS X. I’ve done the manual boot loader - jumping SDA and GND but still not getting connectivity to RoasTime. I downloaded RoasTime 2.5.5 to attempt updating the firmware and that also did not work. 2.5.5 still did not see the roaster.

Swapped USB cables and USB ports.

Swapped to a windows machine, ensured I had the latest drivers. During the install of 591 stable, both windows and mac machines lose connectivity and tell me to contact support.

Frustrated to say the least. I scoured the forums and did all that I could read about, but to no avail so far.

1 Like


I had to sleep on it, I was so frustrated. Nothing was working. I woke up and read more forum posts, it had to be there somewhere. The only thing that I hadn’t tried was using the old RoasTime on a windows machine, to update the firmware that way. IT WORKED. Huzzah!!

1 Like

You can fix that firmware problem with a Mac, but it requires downloading RT 2.5. Fix the firmware with RT 2.5, then go back to RT 3.x and it will work again. I keep a copy of RT 2.5 on my MacBook Air, just encase.

1 Like

I was reluctant to post as I was not sure of the common code base of the Windows and Mac versions. Obviously there is a lot of sharing there!

I went through the exact same thing you did, only on windows.

Glad it worked!