Beans syncing in RT v4.1.2, but not appearing in inventory view or roast info pulldown

I noticed that with RT4, the last three beans I added to my inventory on RW haven’t appeared in my RoasTime inventory view, nor do they appear as options when I try to set up the information for the current roast.

The roast-time/beans directory shows 44 files which matches the 39 archived and 5 active beans in my RW inventory. So it appears that the new beans were synced to the RT data store.

I just tried moving the roast-time directory out of ~/Library/Application Support on the Mac to make RT resync all of my data. Again all 44 beans are downloaded, but now I have no beans showing in the inventory view.

Another unfortunate behavior in RT4 is that if I click on the “manage beans” icon in the bean inventory view header, the RT window displays a web view for the RW bean inventory page, such that there is no way in either the window or the menu bar commands to return to the RT user interface.

The latter issue isn’t a big deal for me, but it’d be nice if my beans were returned to me :smiley:

My missing bean was archived with 0kg of stock. Not sure how it got that way - as likely operator error as glitch.

Had another bean that never seemed to have been adjusted though I had a few roasts against it, and another that was likely off because I did multiple orders of the same green and failed to make adjustments to inventory. Everything seems ok on the Roast World side.

@derrxb I still don’t see inventory syncing in RT4. If I remove my roast-time directory and restart, the directory seems to repopulate properly but I have no beans at all in my RoasTime inventory. Is there something in the RoasTime directory that I can remove to get the bean view working again? Or at this point is it better just to remove the app and reinstall?

edit: One more data point is that the roast-time JSON files for the four non-archived beans in my inventory say available: false. If I change the value locally to true, the beans appear momentarily in RoasTime, then disappear again when sync completes. This suggests that the server side state for my inventory entries might be subtly botched.

Hey @john_l,

Thanks a ton for the follow-up! Sorry for the late response, a few of us were on holiday for the past week. I will pass this thread to the on-call engineer to get it in our backlog. We will try to get this fixed asap.

Derrick

1 Like

@derrxb any word on this? still having to work around by setting the bean field on RW after my roast; RT shows this:

image

If you start typing does it show up?

Hi Jacob, thanks for checking in.

No suggestions appear when I start typing. As I mentioned above, the available flag for my active inventory beans is false in the bean JSON files synced to my Mac.

What are JSON files?

Sorry, tech lingo. JSON refers to the format - “Javascript Object Notation”; it’s a way of organizing data. A simple JSON file for a list of coffee beans and prices might look like:

[
  { "name": "El Salvador Miravalle Centroamericano", "pricePerPound": 6.60 },
  { "name": "Kenya Kiambu Fram Farm AB", "pricePerPound": 9.40 }
]

This format is very commonly used when developing web-based applications like Roast World (and Roast Time, which is a web-based app packaged in a wrapper that makes it look like any other application on your system).

When I say JSON files in this context, I am referring to the files that Roast Time retrieves from the Roast World servers to build the database that RT uses to show you everything in the app.

1 Like

This is not good that this issue is cropping back up?? I had same issue a while back when they were working to redo some inventory management code in the back end and @derrxb told me to nuke my bean folder and let it sync from RW again. It worked then (but I kept a copy of the local folder before I nuked it). Given the date on your screen shot this is just last week so it would be a bit disappointing if it ends up being similar issue to what I had last year… :face_with_raised_eyebrow:

Might be a different problem, as deleting and resyncing doesn’t fix the issue.

The workaround of selecting the bean on RW isn’t onerous for me as I roast only for myself most of the year. It would be nice to see the problem fixed, of course.

Hey @john_l ,

Can you join the slack (if you haven’t already)? And I can help you debug this. Derrick is actually out for Lunar New Year, so it may be a week before we hear back from him.

https://join.slack.com/t/roastime/shared_invite/zt-h7qicu0g-E_u1DsYGRmLXEQ0czoLweg

i have same problem

I am on Slack as @john_l, feel free to DM me whenever (Pacific time)

@kohaii try updating Roastime and see if it addresses your issue. @mcaillio just pushed a fix and it worked for me. Here are the versions from the SW info tab in the Roastime settings:

image

1 Like