Bug: Can't edit my personal profile in roast.world/me (fixed)

I just purchased a Bullet via Sweet Maria’s and am getting my accounts set up prior to the unit arriving. I tried to edit my profile at beta.roast.world/me to update my personal details, but it wouldn’t allow me to edit. I clicked on the EDIT next to the GEAR on the right side of the page to update my TIMEZONE, TEMP FORMAT, WEIGHT SYSTEM, Etc, but it didn’t do anything. How can those parameters be changed?

Also, I was able to download the V3 of RoasTime but it was by sheer luck that I stumbled upon it. There should a correct version at your link - https://downloads.aillio.com/ instead of the Version 2 software.

I look forward to learning more!

@derrxb might need to help you with the roast.world info but I can say we will soon be updating our links from the main aillio.com page to roastime.aillio.com

We kept the old links until we began deprecating RoasTime 2. We just completed the move yesterday.

  • T

I just went thru this for an additional username and found I had to log-in/-out/-in… a few times till I suddenly saw access to the Edit features.

Yeah, steering you to a RT2 d/l needs fixing!

From you username of JF_AZ I’mguessing you might be in Arizona… ?? (I’m SE of Tucson in Benson).


1 Like

Like @JF_AZ I have the same problem - created an account a week ago after placing my order with Sweet Maria’s and not able to edit my profile on beta.roast.world either. I mentioned this issue in another thread too. I tried login/out several times as noted by @bab but I still can’t edit despite seeing the Edit option on the profile page.

Does the browser matter? I’m using Chrome.

1 Like

Thanks for the info, Bruce. Yep, I’m in Chandler!


I’m using Chrome as well.

And I’m using Firefox. I doubt the browser is the issue, but… ?? You’ve managed to get registered and have a Username. Just makes no sense that given that success you can’t Edit that as well. Unfortunately I have no real sense of what it takes to transition to the new Google servers. At first I had the feeling there was a delay to allow a moderator to approve the account but I’ve been told that’s not the case.

Not a very satisfactory input I’m afraid, but I just tried repeatedly over a couple days till suddenly I was able to Edit. At one point I logged out of Community & Dashboard separately (I forget the order). If you have RT3 installed (or RT2), remember it also has a separate login to R.W. (This is sounding too much like magic! Unfortunately I didn’t keep track of what I was doing.)


1 Like

Thanks for the info everybody. I figured it out. When I finally connected my computer to the actual bullet and ran the RoasTime software, the configuration options became available and I was able to set up the parameters accordingly. Just doing it prior to the computer / Bullet connection wouldn’t work, so any newbs you must wait until you receive the Bullet to make the necessary changes in your RoastWorld profile like USERNAME, TEMP PREFERENCE, WEIGHT SYSTEM, TIME ZONE, etc.

@JF_AZ Thanks for that info that I’m going to have to wait for my Bullet to arrive before I can edit my RW profile info.

It’s a bit counter-intuitive from an identity management stand point why there should even be a dependency there with the roaster. It’s a technical implementation thing/decision someone made I guess.

I think this was an issue related to an issue with a configuration record with some users. It’s related to this issue: Bug: Roast.World crashes related to `PrimaryTempLine` (fixed)

I’ve pushed a fix to production a few minutes ago. If you can’t see it yet, there are two ways to get this showing. You can either:

  1. Close all Roast World tabs and then reopen a new tab (preferred method) . OR
  2. Reload your page and on the bottom left-hand side you should see a message with ‘A new version of Roast World has been release’. and a REFRESH button. Once you click that button, you should get the latest version of the app.