Bug in firmware updating progress bar

In the latest version of RoastTime, the firmware update bar is clickable. If you click on it, the firmware will jump to any progress % you click to. This also seems to break updating, although I can’t confirm it wasn’t just updating in the background that I couldn’t see (I gave it almost 20 minutes before cancelling). I closed RoastTime and updated the firmware again successfully without clicking the bar.

Thanks for reporting this. Clicking it has not effect though, so something else must have happened in order to stall the process.

I ran into an issue as well. I tried to update from 584 to 595 and failed repeatedly. I finally tried 591 and it updated without issue. So I tried again to update to 595 and again it hangs. Gave up after several tries.

The screen shot shows the error message I got indicating a comm issue… the bar at the top which disappears after a few seconds. Disconnecting/re-connecting does nothing. That didn’t occur when I updated to 591. I had a few issues with USB connection when I roasted but eventually got that resolved (new laptop which required several iterations with driver installation to make it happy).


I thought it had hung when it seemed stuck on 1% for a lonnnngggg time, but I was about to reset when it started off working. It got to 101% ( yes!) and finished successfully. Maybe some visual indicators or count down or something to try and prove the hamsters are still turning the wheels :joy:

Mmmm… so I guess you’re suggesting I may be a tad impatient? Well that’s never happened before! :innocent: I’ll try again with a little more patient scientific curiosity.


Mine went to 101% too. My second roast resulted in a shutdown. Making me think I had 1% too much of 595

1 Like

You have to unplug it when it hits exactly 100% otherwise you overfilled the firmware and it leaks onto the induction coil putting it out.


1 Like

When firmware is too firm

Hi! I got same experience as Bruce but with firmware 591.
The only different is I stuck at 0%.
I wait about 20 minutes and then unplug the Bullet power and usb cables.
When I re-power up the roaster, everything remains the same. The old firmware version!! (523)

Is there any other way to update the firmware except Roast Time??

1 Like

I’m afraid there aren’t alternate update paths. It’s on the list but we are apparently the only ones with an issue so priority isn’t as high as other bugs being stomped.


Thanks for the info. So…Any suggestion to me for the upgrade failure??
Where I can download the old version of Roast Time?? Since 3.2.3 works ok.

Afaik old versions are not available for f/w or s/w (unless you have a way of archiving locally). I’ve never tried going thru Support… ??


I was able to get it to update. I clicked update, and just walked away and didn’t touch the mouse or anything after. If you don’t reset the bar, it seems to work.

@alexguo & I both did the long-wait thing with no effect… 20 min for him, couple hours for me. Seems like a missed comm event but ??? I expect to be the lab rat to figure it out so I’ll update here when I know something.


I’m able to find an old version RT(3.1.8) in my download folder, and did again the firmware upgrading.
It hangs up at 1% this time. I left them without touching anything for 30 minutes.
After restart both computer&Bullet, The RT becomes version 3.2.4 but the Bullet remains original firmware version?!