Bug: Roasts are not synching

Hi - my login from 2.5.5 doesn’t seem to let me login to 2.5.7 or v3 of the software. Apparently my password is incorrect or if I try the reset password - it tells me my username is non existent. Can support help?

Hey @dthobhaniklun,

Are you able to log into Roast World? Can you please try and let me know. RT 3 and the new Roast World does support logging in using your password. Can you try logging in with your email + password?

Hi - yes I can get into roast world but there are no roasts in there. My login ID is [email protected]. Which is the ID when I used 2.5.5 and also the same ID for when I am using 3.1.2.

Thanks for your response. Do the roasts show up in RT? If they do, can you perform a full sync? Here’s how you do it on the RT software:

I believe you can also upload a backup from RT2 as well.

Hey @dthobhaniklun

It looks like you just recently registered, so welcome!

I found a couple of issues. Our sync script from RT2->RT3 stopped running last week and it looks like you joined after this. I went ahead and ran that manually to transfer your details over.

As far as roasts go, I am not seeing any in the old RW. Did you roast under this account or as a guest? Also, did you take a backup of your roasts from RT 2.x? If so, you should just be able to import those right in as @derrxb mentioned.


Ive had no issue until today. I roasted 6 hours ago but nothing synced today

Hi there. Thanks for the response.
So actually when I try to log into to Roastime 2.x - it won’t let me log in. Clicking the login button does nothing. I’ve tried to reset the password, but the same thing happens. Hence I can’t actually see if the roasts are showing. Re the back up - I hadn’t created one :frowning:

Some more info…

I can login to roast.world with my username and password. It shows my RT3 roasts.

When I try to login to Roast World - Cup, grade, and analyze your coffee roasts in depth using my RT2 credentials it just hands. I think this is the old version of Roast World right? Any chance the roast history can be shared with me, or is there a way of being able to login to this?


I was roasting Thursday 6/24 and when I went to Roast.World/myroasts, all my roasts were listed as “Untitled Roast” and I can’t open any of the roasts. I thought perhaps this had to do with the migration of the site, but today, still the same. At the top of the page is a box that reads, “Welcome to the New Roast World.” It then explains that RoastTime 3 is necessary to continue using it. I have 3.1.8 on my MBP, so I should be good there. However, I must say, I am not at all amused by this and have no idea how to get my data back. Please help. UPDATE: It’s now 6/26 and nothing has changed. I tried to Resync and that didn’t work.