Bullet in fans on mode after failed firmware update

Hello! I was having issues with Roast Time today and when trying to update firmware it froze for over an hour. I unplugged the Bullet and now it’s in all fans on mode. I’ve read in other threads that this can be fixed by reinstalling drivers and then re-updating firmware. Does anyone know of a link where i can download drivers for Mac? I am unable to access the driver installation through Roast Time.

Drivers only needed for Windows. Try just firmware update again in Mac.

1 Like

Thanks for the response! After multiple attempts at updating firmware I still have the same result: 6 beeps and all fans going.

Have you tried resetting the Bullet to factory default firmware, and then reinstalling the current firmware release?

Okay. Thanks for sending me that. I tried it multiple times and I’m never prompted to reset to factory. When I use the paper clip to connect ground to SDA, I hear only 3 beeps, so I know that portion is doing something. But when I connect to Roast Time, I still only have the option of updating to the latest firmware. After doing that and restarting the bullet I’m in the same place. 6 beeps and fans are on. I’m using Roastime 3.4.0. Is there something obvious that I’m overlooking?

Please try the latest roastime 3.4.1, this has fixed a bug with not being able to update once in bootloader.

Still no luck with the update 3.4.1. Today it just seems to be froze on 1% after the timer countdown. I’m an older thread a user talks about reverting to 2.5 to solve a similar sounding issue. Is that a good option? Where can I locate 2.5 for Mac?

Alright! After downloading 2.5 I was able to update firmware. Now I’m back in 3.4.1 and roasting is operational. Thanks everyone who helped me navigate this!

3 Likes