Bullet R1 v.1.5 unresponsive


#1

Hi,
I just received my Bullet roaster. I performed the preliminary mechanical check, in which I had to tighten the pulley screw that screws in the shaft. I also managed to install the drivers and update the firmware to 475.

The real trouble began during my first seasoning roast, where all of a sudden, 4:45 minutes into the roast, my roaster became unresponsive, and all the parameters on the roaster and on Roast Time froze.
What I mean is, the timer stayed at 4:45, the power at P7, Fan at F2, and drum speed at D9. The profile stopped in its track and bean and drum temperature readings stayed stuck in time as well. No buttons on the roaster worked as well as on Roast Time. This went on for awhile until I unplugged the roaster as a last resort. The roaster wasn’t hot, so I plugged it back in and after a minute the same thing happened.
I even tried it without the laptop and Roast Time app.
I don’t know what’s going on. It preheated properly to 230degrees Celsius like it said in the manual for version 1.5. It commanded correctly when to charge it with beans, and it started the roast cycle before it became unresponsive.
The beans I had in there are still green, they just got nice and warm.
There is no error message or code, and it did heat the roasted properly during the preheat cycle.
Has anyone experienced this?


#2

Which RoasTime version you are using?
I am asking this question because I got the same problem. I have roasted the Bullet almost 2 years with the old sensor never have problem like this.
I just upgrade new IBTS sensor so need to update bullet firmware 475 and upgrade RoasTime 2.1.0
My Bullet was unresponsive as you describe.
This problem is big issue. I have to throw good bean because of this.
Please read my post. I used old MacBook OS10.11.6 + RoasTime 2.0.8 roasting 2 batch without problem. But I like to use my new Macbook but not sure it will happen again.


#3

2.0.6, but it freezes on me even when I try to roast manually without Roast Time.


#4

Wow! That should not happen. Hope to find how to solve it asap.


#5

FYI: I too had a freeze but just one time. Bullet R1 V1.5 RT2.2 latest firmware. 31 successful roasts. On roast 32, following same procedures as before, during preheat at time 6:47 everything froze. On the Laptop (Windows 10) the RT screen was frozen. No clock movement. No Graph movement. Windows did not freeze just RT. The LCD readout on the Bullet was frozen too but the Drum was still turning. None of the Buttons on the Bullet were functional. PRS did nothing. The only thing left to do was pull the plug. A quick replug of power was done and the Bullet returned to normal. This is the only time that this has happened. I have since gone on to do 3 more successful roasts.


#6

Very interesting!
Today I played around with it some more. I updated the Firmware to 478 Debug and Roast Time to 2.0.7 Beta. My Roaster didn’t freeze but when I went into Pre-Heating the Bullet wouldn’t heat up. Temperature stayed and ROR was 0. I then changed the Firmware back to 475 Stable Release and updated Roast Time to 2.2.0 Beta and now the Pre-Heat started normally and went to about 170-180 Celcius when it finally froze. Maybe it is the Firmware(s) because the problem shifted with a different Firmware installed. Maybe it’s not the Firmware but the PCB as other roasters would have had the same issues? I also try to give it a minute after the Firmware update to make sure it updates completely. Maybe I am missing something?


#7

Just to kind of wrap this post up, Sweet Maria’s had a replacement unit sent to me and everything is fine with that roaster. Aillio was thinking that it was most likely a PCB problem, but I don’t know for sure since I got a replacement unit.
Thank you for the input and replies!


#8

I forgot to update. Now Bullet R1 works perfectly. Overlay graph, Playback, Back to Back 3 roasting No problem at all.