Can’t connect to Bullet

I received my new Bullet earlier this week. Mechanically everything seems to be working just fine. However, it refuses to connect to the RoasTime software. Here is what I have tried to date:

  1. Uninstalled and reinstalled RT 4 multiple times with both Shutdows and Restarts of the laptop
  2. Uninstalled RT 4 and installed RT 3
  3. Installed RT 3 on a different laptop
  4. Tried multiple cables
  5. Tried switching to a different USB port on both laptops
  6. My primary laptop is running Win 11 Pro, the second laptop is running Win 10 Pro
  7. Tried to update the drivers via the settings in RT in both RT 3 and RT 4
  8. Tried to update the firmware via the setting in RT - get an error saying my bullet isn’t connected.
  9. Tried using the Zadig utility, when I select all devises, nothing related to the Aillio/Bullet shows.
  10. I tried contacting Aillio help desk - after asking for pictures showing both the USB and Micro USB connection - silence.
  11. Tried contacting Sweet Marias (this is where I purchased my Bullet) help desk-no response.

So - to my new friends - what should I try next?

In the past, i have had success with removing RoasTime 4 and puttimg 3 on.

I have been using RT3 for the last 5 months. Had issues today and went back to 4 and it worked.

Good luck!

Install RT4 and download the drivers. RT3 has issues with comm which interfere with d/l of the f/w- most reverted to RT2 to do the d/l when RT3 was current. RT4 fixed that with technology that’s similar to Zadig. I just installed f/w 610 with no issue whatsoever. I have Win11 Pro on my laptop.

I don’t recall if Aillio support is in Taiwan or Bangkok or both but either way they are at work now (Taiwan is at GMT +8 hrs; Bangkok is at GMT +7 hrs; here in Benson, AZ we are at GMT -7 hrs).


Can you check that the bullet shows up in the device manager?
Is your computer perhaps blocking installing the drivers?
First thing to check is that the device manager see the bullet when you connect it.


Thanks for the note. No Aillio LTD (or anything close) does not show up in the devise manager listing. I do have anti-virus running although I have suspended it during the driver install. I will try that again.


1 Like

Received a new control unit from Aillio. Installed and my issue has been resolved. Thanks All!