Can't install dependencies after installing Roastime 4

After I installed Roastime 4, the dependencies won’t download. It will take 3 minutes to install then the window will say that the ‘installation is not responding’.

Any workaround for this?


Did you connect the Bullet to your computer while installing the dependencies? Which Windows version are you on?

Best regards,

Hello Kevin,

Yes, the USB is connected to my laptop while installing the dependencies.
I have a Windows 11 version:


Understood. Please write an email to [email protected]. We’ll discuss this with our software engineers in the meantime.

Best regards,

Thanks Kevin, I’ll send a message later.

Hey. I have kind of the same problem here. I was roasting on RoasTime 3, decided to try RoasTime 4 so downloaded this and tried to install it. It just wont let me

  • If I try to install dependencies it does as pandebonitabiz.GYM9 says here.
  • if I try to run it witdhout installing the dependencies I just get a white screen and nothing more happens except it says “svarer ikke”/“not responding”.

I have tried to troubleshoot through all the things I could find here in the community:

  • deleting everything including the folders in “roaming”
  • turning off both computer and Bullet, unconnenct, fire both up again and connecting the usb and THEN installing RoasTime 4 - still didn’t work

I was looking for RoasTime 3 to download and run again, but I couldn’t find it.

@da_kevin Did you manage so solve the issues here? Anyway I could maybe get some helt too? :slight_smile: Would be great in anyway possible as I’m using the Bullet for my little micro coffee roastery business… :slight_smile:

På forhånd tak! / Thank you very much in advance!


Hi @mikaristeffan,

If I recalled correctly, @pandebonitabiz.GYM9 was able to install the app dependencies on a different device. What OS are you on? Could you try using zadig? Here’s how:

First power up your Bullet.
When it is ready connect it to your laptop/PC using the supplied USB Cable.
Download Zadig from here:
Run the downloaded file (zadig-2.7.exe)
Choose “Options” and make sure “List All Devices” has been checked.
Choose the “Aillio LTD….” Interface. If there is more than one interface choose the one that ends with “1”.
Click ”Install”.
When the installation has been completed, restart RoasTime 4.

Please let us know if this solves your issue.

Best regards,

Thanks for the reply, @da_kevin . Unfortunately it did not work, no.
Tried what @rtuttlejr said too, but that didn’t really work for me either.

I’m on a Windows 10 computer. Anymore suggestions I can try?

Thank you very much in advance!

Best regards,

Hey @mikaristeffan - if you are moving from RT3, it uses the same drivers as RT4, so you do not need to actually install anything most likely. The white screen is almost always caused by a data integrity issue.

What folders did you delete? There are 2 or 3 I believe depending on your platform (roast-time, RoasTime, and/or roastime). If you continue to have problems, I am happy to jump on a call with you.

Hi @mcaillio,
thank you very much for your reply! I haven’t been able to install RT4 no. I tried to buy another USB cable to check if that was the problem, but that didn’t fix it either no. I found out, that I could still download RT3 from the page (didn’t see that at first), so I did that and managed to install it. So for now I’m running RT3. But I guess, it would be great to be able to switch to RT4, since RT3 isn’t being updated anymore, as I understand. So yes, if we could plan that call, that would be great. Friday before noon is preferable for me. How’s that for you?
Best regarids, Steffan