Connection problem with RoasTime

I’ve been having problem while connecting my R1 with RoasTime on my laptop(Windows10).
I’ve checked all of the suggestions on the official website and this community - including “re-installing while connected”, “Force driver update” and so on, but nothing worked for me.
So now, I’m suspicious about my USB cable. I tried USB AM to AM cables both with 2.0 and 3.0 version. Should I use another one?
Or I will appreciate any other recommendations for this connection problem.

1 Like

If you’re using RT 2.5.x, I’m surprised that you’re having an issue. Are you using the cable supplied with your Bullet? In general, I’ve never had an issue with RT recognizing the Bullet on my Win10 laptop. When they were prepping for the V2 power board several months ago I recall an issue with USB comm, but not since that time.

There have been a couple occasions I had to disconnect/reconnect the USB cable but RT immediately recognized the Bullet. Those 2 occasions were when I powered up the Bullet with the cable already connected. Apparently RT expects to see the Bullet already running when it launches.

Just an afterthought- if you haven’t already, you might try using a different port on your laptop.


1 Like

Well I don’t know that the 3.0 version is officially “out” yet (if that’s what you meant) but on Windows I would take a good hard look through your Device Manager looking for rogue COM port associations with the Bullet and uninstall/disable them.

I also had some drivers from AdaFruit etc left in my system which sorta recognised the ST board in the Bullet and tried to cosy up with it, to the detriment of RT. I would strongly suggest trying to keep one laptop just built for roasting with as few drivers and apps as possible. Less of an issue with a Mac due to the way device drivers are generally better behaved.

If you have a Mac to try that would help eliminate hardware problems like cable or USB port. Are you plugged directly into the laptop or via a USB hub ? Eliminate all other USB devices connected if possible too. Got to love Device Mangler even ten generations on…

The USB cord that came with my bullet did not connect to my MacBook Air! I was surprised. I had to use another old one I had laying around.

I always have to insert, remove, and re-insert the USB in my MacBook Air to connect. It has never worked on the first try, and never failed on the second, so I figured it was a feature not a problem. But I suppose you tried that already…

1 Like

Resurrecting an old thread. So I’m having problems connecting RT 3.1.2 to my brand new Bullet V2. I uninstalled and reinstalled the software, tried two different USB cables (including once that came with the roaster). Running on Win 10 64-bit on a repurposed Surface Pro (2nd gen). Windows is complaining there are no drivers for this and “Update driver” doesn’t find anything. I don’t have anything else connected to the Surface (just my bluetooth mouse and keyboard). There is only 1 USB port on the Surface and I know it is not malfunctioned as I connected a USB mouse to make sure it isn’t dead. Device manager recognizes the Bullet when I plug it into the USB (and it disappears from the list when I unplug it). So… I’m at a lost. Any thoughts?

(I had promised @bab I would drop some beans this weekend to season the drum! :smile: )

1 Like

OK… I think it is working now. The driver update had to be done from within RT itself! Wouldn’t have thought …

Good news. So… you’re out of excuses: now it’s time to season that Bullet! :joy: