Editing the wrong entry after a roast [RT v3 only; Upgrade to RT v4]

During pre-heat, during the roast, and following a roast I edit the name, temp, weight, comments, and other details. The last 4-5 times I did back to back roasts, I find out that I’m editing the first roast and not the second when I truly am intending to edit the details of the second roast.
This results in both roasts having the same name, and overwriting the time, comments, and roast weight of the first roast. (Very frustrating)
I’m going to leave the possibility that it’s a user workflow error, but it certainly seems like it’s a bug or there is a step in workflow that the UI totally tricks me to edit the wrong roast.
It’s also important to not that I’m editing the upcoming roast during the pre-heat between batches. RoasTime seems skip from the new roast to the last one and/or when I hit “go back to roast” at the end of a roast, i’m skipping to the first of two (?!)

Anyone else experience or report this issue?

1 Like

hmmm realized i was on RT3.4. I haven’t been paying attention to upgrades… :man_facepalming:
Given that it’s unlikely there would be support for the old version I upgraded to 4.3.2 and will see how the next roasts go.

The entry of roasting details is much improved in RT 4+. The Copy button is especially useful during B2B roasts since it retains the details of the last roast, so keeping track of the current one is easier.

As @cash0612 mentioned, there has been improvements to the editing experience in the newer versions. If you’re interested in giving RT v4 a try, you can the installation files here: https://roastime4.aillio.com


1 Like

I’ve immediately had a bunch of issues with v4.3. Can’t get it to stay connected or engage reliably with the roaster. Can’t get beans to update. Application freezes. :frowning:
Y’all do a lot of work and support but it seems like some updates do more harm and wasted weekends than good

One solution could be to try slowing down and double-checking which roast you are editing before making any changes. It may also be helpful to write down the details of each roast on a piece of paper to ensure that you are editing the correct one.

Another solution could be to contact the RoasTime support team and report the issue. They may be able to provide you with a solution or a workaround, or they may be able to fix the issue in a future software update. It’s also possible that other users have experienced the same issue and have reported it to the support team.

I have issues with this, but I assume it is because I have an old, slow laptop. It will lose a record of an occasional roast, or not start the roast when I drop the beans, or lag from several seconds to even minutes behind the data the roaster is recording when running recipes. New computer is on the list…

Oh, I’m pretty sure it’s just bugs. My computer is plenty fast and this happens to me frequently.

I have several unlabeled roasts. version 3.4

Definitely not editing the wrong roast. Everything is blank before filling it out, and then when I save it, it overwrites the previous roast and creates a partially blank new roast with the same name.

I have the same experience with editing issues even if I make edits after a few days after roasting , not sure what version I am using though.

Hey @jamesphenleyjr.NUIz & @gabyritaseek.qiAO,

I check both of your most recent roasts and you both seem to be using RT v3.4.1. As mentioned in my earlier comment, this might be an existing issue in RT v3.4.1.

I’d recommend trying RoasTime v4.6.6 as this is for sure no longer an issue on there. You can download and install here: https://roastime.aillio.com


1 Like

Hey @fwbennies,

Sorry for the issues you experienced with RT v.4.3. We have released an updated RT v.4.6.6 that fixes an issue users had with connecting to the roaster. Would you be willing to try to upgrade again?

I’m afraid this issue more than likely won’t be fixed in RT v3 as we did a major overhaul on RT v4. I’m happy to help debug any issues you experience with RT v4.


God bless you Derrick and thanks for your kind and valued follow up and the link.
I will aim to update to RT v4.6.6 over the coming days and see what happens. I am overall most happy with RT v3.4.1 and has been very stable for me with no main issues whatsoever. Thanks again for a great machine and superb service.

Kind regards


Yeah about that. I tried “installing” v4 on Linux Mint. And of course I immediately tried to put a shortcut on the taskbar. After two days of frustration I went back to v3 and decided to just work around the problem. I refuse to write a script or hack the OS just to do something so simple. Until you have a version that doesn’t break every Linux convention I’m sticking with v3 until the wheels fall off.
It’s not like I am some computer noob. I am a retired IT Director and have used some version of Unix or Linux since around 1980 starting with SCO Xenix. I used Ubuntu until they changed the interface. I like Mint because they DID NOT try to reinvent the wheel. I have my workflow methods and this dog is too old to learn new tricks.

Hi Derrick,

A quick question please. Should I ever need to go back to RT v3.4.1 after upgrading to RT v4.6.6 for any reason, how would I do that?

Thanks in advance for your kind assistance.


Hey @gabyritaseek.qiAO,

You should be able to simply re-install RT v3 if you’re on Windows. On Macs, I believe you just replace RT v4 in the Applications folder with RT v3 (this is what you do when you open the Mac installer).


Thanks again Derrick,
I will keep this in mind should I ever have to go back to RT v3.
I am using a Mac by the way and overall super experience with both the software and the machine. :crossed_fingers: :crossed_fingers: :crossed_fingers:

Thanks again…

Thanks @derrxb I’m running a 4.6.16 and able to connect and roast better now. I like a lot of the improvements.