ErC 0001 error help needed


#1

'm just a few months into roasting on the Bullet. I got the Bullet from Sweet Marias in September/October. I’ve had very few issues as I’ve learned to roast on the bullet. I’ve had pretty good success and some good coffee. Now I’m not sure what has happened, but I can’t get out of preheat mode without the alarm and an Erc 0001 error. I’ve never encountered this before in any of my previous roasts prior to tonight. This is my first attempt at roasting since my first real cleaning of the roaster after my Christmas Season roasting. I followed the Sweet Maria’s videos for doing the “yearly” cleaning. I cleaned the fan impeller and back end of the roaster. I then took off the face plate and tried to clean off the inside of the face plate. All seemed to go well. But when I went to preheat to roast this evening, as the roaster preheated the alarm sounded with the erc 0001 error. I initially misunderstood the error to erc 1. The manual indicated that I was to cool down the roaster. This seemed to occur around 262 C. My charge temperature was set for 282. I let the roaster cool and then tried again several times with the same error. It seemed too coincidental that this is my first attempt at roasting since I cleaned the roaster this weekend. I posted on the Facebook group and it was suggested that I might have loosened the connections on the control panel when I opened the faceplate to clean it off. Then I realized that it was the erc 0001 not erc 1 error and this was a strong possibility. So, I did as suggested and I checked the cable connections. They all looked in place, but I pushed them in to make sure they weren’t loose. I put the control panel back in place to try again. No success, still getting the erc 0001 error just as it approaches the charge temperature. I’m at a loss as what to try next and I need to roast some coffee. I’d love some suggestions as to how to troubleshoot and remedy the situation. Thank you for any help!


#2

First off, open a Ticket with Aillio help desk (or contact Julio at Sweet Maria’s if that’a where you bought your Bullet).

There’s a possible issue when checking connectors in the control panel that a bad connection may not be because the connector isn’t seated but rather that one of the pins (either in the cable or at the PCB end) has backed out. It can happen if a pin isn’t swagged properly, isn’t seated entirely in the cable connector, or if it’s soldered, because of a cold solder joint (the solder didn’t spread properly). It’s hard to spot so take your time as you look the connections over carefully.

There is also a remote possibility that the issue is at the power board end of the power comm cable, but you should probably be in contact with a help desk before you start an Easter egg hunt.

There are probably other things to check but they’re beyond what I’ve read about here. Things like broken wires or corrupted f/w come to mind, but that’s best left to a guide that has traveled this road before.

Bruce


#3

The ErC 0001 is the bean temperature from the classic probe which is becoming too high.
It would really help if you were connected to RoasTime and could take a screen shot of the error log and perhaps a screen shot of the preheating phase.

For the error to happen there could be something wrong with the:

  1. IBTS, if this is dirty the bullet might preheat too high and you will get the error
  2. The probe is defect and needs to be replaced (or the two pin connector is loose on the control board)

It is difficult to investigate more without having some data to look at.

Jacob


#4

Here is the log from RT2, is this what you were referring to?

[{“code”:41,“value”:245},{“code”:41,“value”:246},{“code”:41,“value”:246},{“code”:41,“value”:247},{“code”:41,“value”:247},{“code”:41,“value”:248},{“code”:41,“value”:248},{“code”:41,“value”:247},{“code”:41,“value”:246},{“code”:41,“value”:245},{“code”:129,“value”:65531},{“code”:46,“value”:93},{“code”:28675,“value”:1},{“code”:32769,“value”:0},{“code”:28675,“value”:1},{“code”:32769,“value”:0},{“code”:32781,“value”:0},{“code”:29468,“value”:140},{“code”:32781,“value”:0},{“code”:29468,“value”:140},{“code”:29467,“value”:95},{“code”:29448,“value”:651},{“code”:29467,“value”:95},{“code”:29448,“value”:651},{“code”:28674,“value”:3},{“code”:28672,“value”:57671},{“code”:28674,“value”:3},{“code”:28672,“value”:57671},{“code”:28673,“value”:40564},{“code”:32781,“value”:0},{“code”:28673,“value”:40564},{“code”:32781,“value”:0},{“code”:32769,“value”:7713},{“code”:32769,“value”:7713},{“code”:41,“value”:245},{“code”:41,“value”:246},{“code”:41,“value”:246},{“code”:41,“value”:247},{“code”:41,“value”:247},{“code”:41,“value”:248},{“code”:41,“value”:247},{“code”:41,“value”:246},{“code”:41,“value”:245},{“code”:28675,“value”:1},{“code”:32769,“value”:0},{“code”:32781,“value”:0},{“code”:29468,“value”:140},{“code”:29467,“value”:95},{“code”:29448,“value”:651},{“code”:28674,“value”:3},{“code”:28672,“value”:57671},{“code”:28673,“value”:40564},{“code”:32781,“value”:0},{“code”:32769,“value”:9199}]

I have attached a few screenshots from a video of the roast. The video was too large to attach.

I thought the IBTS on the V2 were self cleaning? How should it be cleaned?

I have reconnected the connectors on the control board to make sure they were seated tightly.


#5

The data shows that your bean temp is getting above 245deg C which is why it’s shutting down.
You maybe have a dirty IBTS. Please take off the front and have a look at the IBTS. Take a few photos. The sensor should look like a mirror.