ERC 6864 Fix


#1

FYI today when I fired up my roaster I got an ERC 6864. The Info panel confirmed 0 RPM on the IR fan. I had issues with the IR fan when I first got my machine and it required a new board, so I was bummed. However, the fix was simple.

It turned out the problem was simple - one of the connectors at the fan had worked itself loose enough to a cause erratic fan behavior and/or not report RPM to the roaster control board. I found this by disassembling the head unit & checking the connectors.

Just an FYI if others get this code - check the connectors first and hopefully you will have a quick and easy fix


Removing the IR sensor
#2

Damn, just got my bullet and been getting this error as well. How do check the connecters?
im on 558 firmware btw

Is it the front panel of the machine or the end/chaff collector side???


#3

Alsannaa,

First, the caveats: I am not an Aillio expert and I take no responsibility for goof ups! :wink:

To check the connectors you need to disassemble the control unit on the front of the machine. Be careful - the wiring harness and plugs that connect the components are delicate so be careful not to pull to hard on wires. If you want to disconnect & reconnect a plug, I use a thin blade to move the plug, don’t pull on the wires. Also, I do the disassembly with power unplugged but, once pieces are safely positioned after disassembly (i.e. no chance of shorting across connectors) I do plug the machine back in to check if the fan is running etc.

The first thing to check is the IR Fan speed under the ‘i’ info window (upper right on Roast Time). If it shows 0, then I would start digging. First remove the face plate on the control unit, then remove the black screws holding the PC board in place. Behind the PC board, you should see a hole on the lower right side of the housing that holds of the control unit (about 1/2" in diameter). The fan resides behind that hole.

I would carefully unplug & reconnect the connectors on the PC board that lead from that hole. Also check that the connector pins are straight, properly soldered to the board (when I had my problem, some noted that they had see pins come loose). To actually check the fan assembly, you need to remove the housing, but before that I would use a hex wrench and lightly push on the connector that you can see through the hole to ensure it is properly seated (that connector was my problem).

If no success so far, you can remove the housing and access the fan assembly. Again, I would disconnect/reconnect the plugs, check pins etc. to make sure you have a good connection. I would also check that the fan is free to spin - make sure none of the slack wire from the connectors is interfering with the fan.

Best of luck!
Bill


#4

The error can also be an issue with the fan itself (if you consistently get an rpm reading, but it isn’t high enough). I had to replace mine, but Aillio sent a new one with speedy delivery!