ErC 6864 + terrible motor noise

Performed a deep clean on a Bullet I recently purchased from a contact. After reassembling, I plugged the machine in, and after a few moments go the ErC 6864 error.

When I tried to go ahead and move it through some of the modes, I also got this terrible thumping noise when the exhaust fan kicks on (at least I think that’s where the sound is coming from).

Video here -

Has anyone else had this happen? Any thoughts on what I need to do to troubleshoot both issues?

I have read about the ErC 6864 error and how I might need to remove the face plate to clean the build-up around the IR (I haven’t done that yet, only cleaned the surface lens of the IR with a q-tip and alcohol as instructed).

I am a little bummed that I may have caused this somehow cleaning it. :frowning_face: :face_with_peeking_eye:

ErC 6864 refers to the IBTS cooling fan speed… should be on the order of 16,000 rpm though the low limit is (i think!) 5,000 rpm.

The sound is likely coming from the drive pulley at the rear of the drum shaft… maybe the belt slipping (??). Go thru the online manual for adjustments of belt tension. Also there’s some setup info on the Aillio site under Support. It’s unlikely a thumping noise is related to the exhaust fan.

Unless you removed the drum when cleaning it’s unlikely the issues are of your making. These things are pretty tough though they can be fussy about adjustments & cleaning.


Thanks, Bab. I came across your previous posts about this error, so I know you have a lot experience dealing with it!

How can you see the rpms? I am just getting setup and had turned it on so that I could get my RoasTime setup, so I don’t have the machine in sync with my software yet. Is that where you can see the rpms? I am definitely not able to see them on the face plate.

And good to know you also think it’s the belt. I also thought that it could potentially be the belt just by the sound. Similar to car belt, I thought. So I’ll look at that, too.

There weren’t any issues with the machine before that I was aware of, so the only change was the cleaning.

Connect the Bullet to your laptop and open up RoasTime as if youre roasting. When you cycle thru the modes and the graph is showing you’ll see an “i” in a circle on the upper right, click on that to open the info panel. You should see the RPM (along with a bunch of other readings) there. Bruce maybe able to tell you better than I do exactly what it’s labeled as.


What @blacklabs said… it’s right on the money.

I believe the Info panel lists the IBTS fan as IR Fan RPM. Nominal speed is 16,000 rpm. F/w allows a low limit of (I think!) 5,000 rpm but if the fan is that low it probably needs to be replaced. The Info panel is only available on the Roast screen with the Bullet Connected. ‘Connected’ refers to the indicator at the top right (if you’re using RT 4.x.x) and means RoasTime can communicate with the Bullet. The Info panel isn’t available on the other screens in RoasTime. If the Bullet isn’t roasting or preheating many of the measured values will be blank.

I see that the online manual no longer shows a sample screen. I tried to find an old screenshot but it’s from RT 2.x.x and I’m not sure it’s accurate.

I believe the Online manual contains info on how to adjust the tension of the drive belt (go to and click Support to see what’s available for users to help with repairs/setup/roasting). That setup process varies with the version of the Bullet. I believe that will get reported on you roasts in Roast.World-

The version info is lower right in this screenshot. Mine is listed as a V2.0. It was born as a V1.5 but I have since replaced the control board and the power board. F/w checks those 2 config items and reports that in the Info screen. Once you get to Roast mode you’ll see similar info for your Bullet at the bottom of that screen.


Thanks Bruce and Blacklabs… the roaster is new to me, so I am essentially ‘unboxing’ it even though it’s used. I have setup the RoasTime software on my laptop, but the software isn’t recognizing the roaster, so I can’t get any reads from it. I have tried updating the firewire, but that won’t work either because the roaster and software aren’t recognizing each other so it can’t download. I have also looked for driver updates, but I do not seeing any when I look at RoasTime (I’m on a Mac).

I did not remove the drum to clean. I did reset the drum, though, after cleaning it as mentioned in the manual.

I took the chaff collector off to get a better idea of what the noise is, thinking the noise might be coming from the exhaust fan impeller hitting the side, but I don’t think that’s it because the noise doesn’t happen when the machine first starts up. At startup, the impeller moves without noise and with ease. It’s when I try to put the machine into pre-heat, and beyond that, the thumping noise starts.

I will try tightening the motor pulley to see if that rids me of the noise.

But then I still have issues with the ErC 6864 code. Without the RoasTime software working, I am kinda flying blind on data.

With that in mind, trying to think about what to do next. I feel like the fan needs to get calibrated potentially, but I can’t do that with the error message.

Maybe it’s time I reach out to support directly.

I haven’t tried taking the face plate to access the IBTS fan is dirty or eroded. Perhaps I should try that as well?

I grabbed two more videos of the machine running with the chaff collector off to better hear the noise

1. Vid 1 - 19 sec - startup with no noise
2. Vid 2 - 41 sec - when I force the roaster to go through modes

Just reread you note and see you are using a Mac. Unfortunately I don’t speak Mac. So…

I have had great help from Aillio Support. I wouldn’t hesitate to ask them for help via e-Mail. Unfortunately Support is in Taiwan so you have to deal with time differences.


1 Like

Alright, made some progress with the roaster today. Fixed the pulley that helped get rid of the noise.

After troubleshooting and forcing some firmware updates, I got my software up and running. So, now I can at least show the IR fan.

Still getting the ErC 6864, but it makes sense because my panel is not registering the IR fan. IR Fan RPM is 0.

This is an image of the machine in pre-heat and roast.

Panel in preheat

Panel in roast

I was getting this error following a deep clean which included the IBTS. I took apart the front panel and carefully blew some air through the IBTS fan, reassembled everything, and the error never came back.

1 Like

Three possibilities come to mind-

  • the IR fan blades are contacting the mounting surface and the fan can’t move. The fan is accessible via the control panel pedestal- start at the panel and work your way down. Iirc, the pedestal will have to be removed to expose the fan. Search here for related posts & photos.
  • there could be a connection problem with the cable from the fan either at the fan end or the control board end. Again you’ll have to go thru the control panel/control board
  • the fan is simply dead and needs to be replaced

I believe Aillio has some info on the web site under Support which would be a starting point. Fwiw, I had to replace that fan early on (mine was running too slow). No harder than what you went thru with the drive pulley. Just be careful to not drop one of the screws for the control board. Take photos on the way in to help you remember how connectors are oriented (keep track of the wire-color orientation as well as location).


1 Like


So I finally got time to work on The roaster today. Took the panel off to get to the fan. And here’s what I found.

From your experience (or others) does this type of build up often cause the ErC 6864 error and/or need for fan replacement?

Yeah, that will do it.

A fan, spinning at 16,000 rpm, ought not have that kind of build-up. The fan looks like it’s dead. Looking back at your screenshot of the Info data, I see IR fan RPM = 0 which is your confirmation you need to replace the IR fan.

So… welcome to the elite club of owners that have had to replace the IR fan. The initiation rights require that you get a replacement fan from Aillio, or more likely a dealer, and install it. Easy-peasey! I don’t know your location but if you’re in the US you should be able to get one sent out from Sweet Maria’s (in California); there’s an east coast dealer as well which ought to pop up on the site.

Just to do a little due dilligence you should probably fuss with the connectors to be sure it’s not simply a badly seated connector or an unseated pin in a connector body that was pushed back.


Edit: Just for the record, I received my Bullet in Jan 2019 and replaced the IR fan in (I think!) about May 2019. I’ve had no issue since.

1 Like

After taking the little fan off, cleaning it up a bit, and putting everything back together I just turned the Bullet on. The error is gone!

I checked my RPMs and they aren’t quite 16000 - hovering around 15400 and 15680.

I wonder if I should go ahead and order a replacement fan, just in case.

Thank you for continuing this saga with me and for all your help! I feel like in troubleshooting both of these issues, I was forced to learn a lot about the bullet’s mechanics quickly as a newbie, so for that, I am thankful.

I’d suggest getting the fan on order as you start using/learning your new-to-you roaster. Something probably has a poor connection (back to checking connectors/wires) and that includes possibly something internal to the IR fan. You may never use it but if it were me I’d consider it a warning and would feel better having the spare on hand.

From the look of the fan, that (probably!) poor connection has been around for awhile. There is also the possibility a fan blade was contacting the rubber mounting surface the fan is attached to- that would keep the fan from spinning.

I see just under 16,000 rpm as I start preheat. The fan speed creeps up a little as the roaster gets up to temp.


1 Like

@bab Bruce… what do we do without you helping so many ppl troubleshoot??? @jacob should compensate you for being what amounts to their first line of support ! :slight_smile: I know you’re doing this out of the goodness of your heart but this is time consuming stuff.


Thanks for the kind remarks @blacklabs . I do it cuz I can- retirement has provided time to give back. I’m afraid if folks were aware how old the source is they’d probably just start looking for the delete key. Fortunately there isn’t one so I’m safe for awhile longer!! :roll_eyes:


@bab I have learned so much from you and your shared experience in so many threads (not just this one!)

We all owe you a big thanks for your time and help. I know it’s helped me!

1 Like