Firmware problem (again?) 591 to 605

Hello Everyone,

I tried to upgrade my firmware to beta 605 today and ran into a problem similar to one I had quite a while back.

The progress bar never moved, the timer timed out, and it told me that it could not communicate with the roaster.

I powered down the roaster, and when it booted I got the “Three Beeps” letting me know it was in bootloader mode.

So I reloaded 2.x (I think it was 2.4.7?) and reloaded the 591 firmware. This, too, told me it could not communicate with the roaster, but it was lying. It downgraded fine.

I shut down, disconnected, and reinstalled 3.x (3.4.1 to be precise) and I am now roasting away contentedly.

Any thoughts on the firmware upgrade problem? Anyone else see this? I am a version 1.5, currently roasting my 249th roast.

Thanks,

I just had the same problem trying to update from 602 to 605: it went into full-fan mode and countdown from 1:30-0, then said it could not reconnect to the Bullet. I shut everything down and waited 15 seconds, then started up RT and plugged in the R1. The first few times, the Bullet stayed in full-fan, but after factory resetting (GRN-SDA), I could start back up into 602. I tried a few more times, but gave up. I am now still able to use 602 and roast.

Downgrade to Roastime 2.x then login as guest… Upgrade and reinstall 3.x. Worked for me.

I saw that, but unfortunately deleted 2.x a few weeks ago.

@dpiette where did you find the older f/w ? Or does the 2.x do that for you? I’m be very hesitant about upgrading my f/w (on 562 which came with my Bullet v2)

I had a saved a copy. If you can’t find one here, let me know and I will put this in a google drive and give you access.

Did they delete all the old copies?

1 Like

I think you can get it here: Legacy RoasTime - aillio

Thanks @dpiette I do have the 2.x RT software downloaded, but you mentioned the older firmware version downgrading, so I wasn’t sure if you saved the file or did that just occurs when you installed the 2.x RT software? TIA.

I downgraded to the 591 Stable, which was still on the 2.x version.

Got it… thanks.