Firmware update issue

Firmware update bugs after the 1min30 startup timer : indicate to contact devs

Got an used R1 that’s still on 5.15, would like to update!

Does it connect to RoasTime normally?
Which serial number is your Bullet?

The serial number is 001149

The roaster does connect to RoasTime for roasting and seems like “normal”.

When i try the firmware update, after it crash, RoasTime indicate "unable to connect follow these steps to reinitialize your Bullet (* bold being an HyperLink that dosen’t work btw*)and the Bullet seams to be trapped in this weird firmware update fan all out mode…

While the fans are running full power in this mode, try to restart RT, then install the drivers again, all the while the bullet is connected. After this, try updating FW again.
Basically you want to install the driver again, while the Bullet is in boot loader mode.

Tried it… and it failed?

The driver installation sub-menu pages load quickly, pop a windows access window, and then the black installation screen briefly opens and fade away.

Still stucks on that:

I’m having exactly the same problem. I just fitted the IBTS upgrade to my V1. The roaster and roastime still connect but I need to update. When I try this I get exactly the same problem as you. I’ve tried on two different computers and have uninstalled and reinstalled roasttime to no avail… Any ideas what to try now?

Coud’nt get it to work.

I guess we’ll have to wait for Aillio themselves?
That’ll refrain me to upgrade for the IBTS for the moment

1 Like

If you are on windows can you please confirm that the driver is correctly installed when you are in bootloader by opening up device manager then the bullet should be shown in the bottom under USB Serial Bus devices.
You will know the bullet is in Bootloader mode when the fans are spinning at full speed and it just beeped a few times.

I was given the advice (by Aillio) to try installing this older version of roastime and using it to update the firmware. Sign in as a guest first then update the firmware. If this works you can then deinstall this older roastime version and reinstall version 3.4.1 This solved at least the driver problem for me although I’m still having other problems. (However I’m confident I’ll get these sorted too and Aillio support have been enormously helpful.) Here’s the link to the old Roastime:

Hope this helps

1 Like

Thanks Mike!

I haven’t found the time to check the USB connection lastly suggested by @jacob, I’ll check that asap.
On another note, i can confirm the Bullet is on bootloader @jacob (3 beeps and fan max).

I’ll also try the Legacy solution cause it seems like the drivers update also fails, or that i already have the latest (black window opens, gets on the “installing latest drivers: _” part an stays there.

Firmware issue solved! I went trough the legacy version and it worked. As for the drivers, the windows stays still on this bit: