Hard reset?

First seasoning roast.

My board locked up at 8:34 at 185 not allowing me to change any controls.

I unplugged it. Now it will not start. The light true a no, the cooling fan is on, but no power to the board and the drum is not spinning.

It beeps six times and has a blinking red light by the cooling fan plug in

Is there a way to hard reset?

Any thoughts?

I suppose there are several reasons that could cause this but I’m not aware of any that don’t involve replacing a component. There is a cold-boot procedure on the Aillio.com site that is used for d/l’ing firmware but that seems extreme for a new roaster.

I’d suggest going to Aillio.com, click Contact and start a trouble ticket so Support can get you going again. Taiwan is 11 hrs ahead (I’m in Mountain Standard Time) so you may find someone there to respond. The process involves a support person guiding you thru some troubleshooting and making a recommendation- that may be procedural, may require parts, or… whatever. But nothing will happen till they (or your supplier) figure out what’s needed.

Bruce

After attempting the manual boot load a second time, the bullet was able to update to latest firmware and is working!!

Forgot to mention aillio and sweet maria responded promptly and were very supportive. That is a good way to fix a rough start.

As an aside, when using the boot loader to update/reload f/w, after the f/w loads you had to disconnect power and the USB cable. I found I had to do it over and over to get a proper restart until I tried disconnecting power and let the roaster sit for something more than 15 sec. After that long power disconnect it started up properly. When I was having trouble it was apparently because I powered off for only a few seconds.

Bruce

1 Like

Hi @bab. I just had the same issue with my roaster not responding at all. Do you know where I can find info on the hard reset? @aillio doesn’t have a search function on their site so I wasn’t able to search for it. Thanks for the help. @Aillio please help if you can!

Quick follow up. I was able to locate a URL to the hard reset here: AILLIO BULLET - UPDATING MANUAL BOOTLOADER - Docent Coffee.

If it beeps 6 times then it is already in bootloader mode and you can continue and update the firmware.
New bullets rarely need to be put manually in bootlader, this is more for older versions that cannot detect if the firmware is corrupted.
Did you fix the problem?

Hi @jacob. Thanks for following up. I was able to get the latest firmware updated, but it was a struggle. During the first attempts at updating the firmware - before the roaster went unresponsive - I kept getting an error message from RoasTime that the unit could not be detected/connected (even though RoasTime showed the unit was connected). Eventually, the RoasTime updater and the unit became unresponsive and froze. I tried powercyling both the roaster and my computer, but I was unable to get the roaster to connect to RoasTime. So I performed the steps to enter manual boot loader and I was able to update to the latest firmware. Is there concern that I had to put to roaster in manual boot loader?

I am glad you got it working finally. It is something we have been struggling with to make easier.
There is only the concern that people could short out the wrong pins and damage the boards. It is also not fun having to take off the front and do this. So in the future if you hear 3/4/6 beeps it means that the board is in bootloader and ready to accept an update.
Cheers

1 Like