HELP! Dead Bullet!


#1

(I’ll preface this by saying I’ve also emailed Aillio support, but as it’s a weekend I worry I may not hear back for a few days. Really hope someone can offer troubleshooting advice.)

Today I fired up my Bullet as usual to preheat, and when I came back to check on it 20 minutes later (the time it normally takes), the roaster was completely dead, no lights, no fans.

I have opened it up and checked continuity on both the rear motor fuse, and the opaque fuse on the main board underneath. Both seem OK. The electrical outlet is also fine, no blown fuses there either. That’s the most I know how to troubleshoot this.

Can anyone please suggest what I could do next to troubleshoot? I can’t face a continued quarantine without home roasted coffee. Thanks in advance.


#2

Did support get back to you yet? Any guidance?

Bruce


#3

You could try unplugging the plug from mains and try another socket. I use an online UPS with my Bullet and it went dead mid-roast a few months back. Nothing worked. Finally unplugged from the socket I was using and plugged in to another one and the Bullet came back on. Haven’t had the issue recur so far. Since you appear to have tried everything else, you could try this too.


#4

Thanks to everyone who responded! Matt at support did get back to me, and unfortunately it looks like my power PCB is dead. On the plus side, it’s a chance to install some upgrades to my v1 Bullet and see what I’ve been missing for the last 2 years (I’ve still been using Rt 1, no IBTS, etc.)


#5

Let us know when you’re back up and running! It’s great to hear successful support stories, even if it sucks to be without a roaster for some time.