How can I install an older firmware?


#1

I’m having so many issues with my bullet that I want to try an older version of firmware. every so often, when I plug the power cable, my bullet starts beeping multiple time and won’t let me preheat over 401F or 205C. Is like it looses the firmware. I use to update the firmware and that usually fixed the issue but not this time. I still see the new calibrated fan option setting this time. I tried to force to update the firmware but nothing happens, I turned off the firewall and still nothing. I’ll appreciate any help you guys can give me. Thanks :sunglasses:


#2

Usually this means a bad connection to your IBTS. You should check the wiring between the control board and the sensor, making sure the connectors are fully inserted into the sockets. I don’t think a FW update will fix your problem. The most stable seems to be 512.
For better understanding your problem please post the error logs from RoasTime after connecting the R1. Please use the latest beta 2.3.1 which gives us more debugging information than the old versions.


#3

VERY STRANGE. I have the IBTS and have been roasting for months with no problems. Last week I updated to the newest stable firmware and roast time and IMMEDIATLY I GET THE EXACT SAME PROBLEM. I’m working with Aillio but the process is slow and I have taken the machine apart and many times and have spent countless hours working on their suggestions and documenting things. I’m waiting for a new control panel (the older version), new IBTS sensor and also info about another error message. I bought my machine last summer and until now it has been great, but now it is toast. I wish I could do a partial upgrade on all the parts (maybe even willing to pay for part of it) and then get back to roasting coffee. I do have to say that although frustrating, that Aillio has been responsive and is trying to help. I may want to take my machine to Sweet Marias to have them deal with it.


#4

Thank you all for the replies, I contacted Aillio, I checked the connections behind the board and everything looks good. They requested some pictures and I just sent them. I also was roasting since January with no problems, once I updated the firmware to the “stable” version, then I started seeing issues. Anyway, hopefully I’ll solve my problem. Again, thank you all.


#5

As Jacob has pointed out, if you did the IBTS as a retrofit check the pins in the socket which you may have had to move (as I did) depending on the PCB type you have. If you don’t get the little clip seated correctly on one or more of the wires as per the install guide photo then you risk pushing the pin out as you insert the connector leading to instant or possibly delayed failure. When I performed my upgrade I checked and also pulled gently on each wire to be sure it was secured. It might save some grief if future kits shipped with adaptors so no pin wrangling is required.


#6

As an “old” mainframe computer trouble-shooter, the part that is telling to me is “the machine was working until I installed the latest firmware”. That doesn’t sound like a connectivity problem. It sounds like a software and or hardware issue.

Also, if a user suspects a wiring connection problem, it is also best to inspect the actual crimps made on the wires in question to make sure the pin and the associated wire are actually making good contact.


#7

Agreed the usual “what was the last thing that changed” is often the culprit. However, given Jacob saying the symptoms suggest a hardware connection problem to the IBTS, I can see a “hardware” scenario with these pins where things look great to start with but fail over time due to heat expansion/cooling. Sometimes its coincidental with something else like a firmware update.

One of the posters said they bought their machine last year at which time the IBTS wasn’t available so that’s another “thing” that has changed - user installed hardware that could be contributing to the issue. Or maybe it’s both firmware AND hardware. And connectivity in this case is hardware - the pins.

As a Sherlock Holmes troubleshooter, "Once you eliminate the impossible, whatever remains, no matter how improbable, must be the truth. " or Trust But Verify. Both of these have served me well.


#8

Given the qty of situations with this product that are either directly a result or suspected to be a result of “pin connections”, there is good reason to check connections. Yes, User performed modifications such as IBTS are always a possible suspect for connectivity related problems and should be double-checked IMO.

I just wouldn’t advise a person (under normal use) to go in, dismantle the product and start pulling connectors to look for pin connection problems. For some users, they could cause a problem that didn’t originally exist. :wink: Beyond loose connectors caused by shipping or a possible manufacturing defect, I wouldn’t expect the Bullet to create pin-connectivity problems under normal use.


#9

Which is why it falls under my Trust But Verify - go in once and verify the pins were correctly oriented if you didn’t take or don’t remember taking pains during installation to confirm you didn’t skip over that note. If you have already confirmed the pins are done right, you obviously have no need to keep doing it as I don’t personally believe in Gremlins :wink:

If they already felt able to retro install the IBTS (rather than just buying one of the later batches from Aillio or SM) then I doubt the dismantling to verify has any impact. If they bought their machine recently with the IBTS already done, fair point.


#10

My response to this particular thread was based upon the (2) people that said “all was working fine until they upgraded to the latest firmware”. If they haven’t been tinkering inside the roaster, have been successfully roasting for quite awhile, do a firmware update and immediately have a problem, it is difficult for me to subscribe to the oft-suggested loose connector cause. Having personally witnessed some of the firmware update idiosyncrasy of this product, I’m more apt to think it actually could be firmware or a failed installation of same.


#11

Yeah @PapasCup we have two types of people in this thread. I was addressing @5thumbs who said they bought the machine a year ago and recently installed the IBTS…

There are always things we know we don’t know :wink: Not arguing against you, just widening the scope on the basis of my previous sentence.


#12

Understood. I hope Aillio can get to the bottom of what appears to cause firmware updates to occasionally go wrong or fail after installation. I’m so wary of it, that I don’t update the firmware unless there is a really good reason to risk it. :stuck_out_tongue_winking_eye:


#13

Well I’m going to doom myself with The Scottish Play curse by saying that I have upgraded my machine with the IBTS and firmware and RT updates without incident. Of course I habitually disconnect the USB cable from the roaster when rebooting after a firmware update so maybe that’s the rubber chicken ritual that keeps me safe. For now.


#14

I’d agree that your “rubber chicken ritual” is the “secret sauce” for warding off the firmware demons. :grin:


#15

All good and valid points. I have experience assembling circuit boards, soldering and wiring, but I went in and triple checked all of the connections and still the same problem. Again, everything worked fine until I was stupid enough to upgrade the firmware an Roasttime. Immediately saw I could no longer preheat to above 401. Lots of random beeping and lights flashing on control panel. Tried to reinstall firmware and bricked the control panel. Was given instructions to reset control panel (by shorting) and reinstall the firmware and control panel became alive, but same problem (cant preheat above 410 and also lots of beeping and flashing and error codes). I have provided pictures, videos and error codes (some of which are for the back small fan) to Aillio and was told I have to wait till they get some new old stock control panels (to be delivered to them this week). Also, should mention that the 1st time that I could not set preheat above 401 (right after 1st firmware update), I initiated a roast and all hell broke loose… The machine did not behave correctly and I could not abort the roast (meaning I could not stop the heating, obviously could dump the beans, but could not turn on cooling fans). I dont mind some troubleshooting but it may be time to send back this machine if things cannot be resolved in short time. Beyond me…


#16

Sorry it wasn’t something super obvious and fixable. I’m assuming you didn’t fit the upgrade wearing your best mohair sweater while stroking your Persian cat :wink:

Unfortunately it seems bricking stuff with firmware updates is a calculated gamble for all manner of devices. I suspect thats why most car companies don’t even go there - who wants to troubleshoot a 4000lb paperweight blocking your driveway!

I would however be very saddened if Aillio team decided that it was all just too much trouble and ceased any further firmware or hardware updates for those of us who already have a Bullet leaving new stuff only for new buyers…


#17

The toughest problems that we typically faced in mainframes were those that were thought to be caused by a single problem/failure, but were found to be multiple problems. That could explain why resetting the firmware had some limited effect (possibly solving parts of a firmware update aberration), but the problem with preheat temps remained. Maybe the “firmware reset” still leaves some residual problem/change from the firmware update that continues to plague the preheat limitation.

We’re not the engineers who designed the Bullet, and I’m really interested in how this particular problem is solved. The worst thing is being “dead in the water” roasting until the problem is solved. Fortunately, the Bullet has a 2yr warranty.

These are the kinds of things that I have experienced with other (long deceased) electric drum roasters where access to company engineering was very limited or non-existent. It is exactly what drove me to build my own gas-fired roaster 10yrs ago. On that design, there is very little that can fail and any of it can be replaced with parts that I can easily source myself. While not as sexy as the Bullet with all of its technology, it is a good thing to have a “backup roaster”. :stuck_out_tongue_winking_eye:


#18

Sorry to hear about your problems. Do you happen to know which firmware worked before you upgraded? I would be happy to do a teamViewer session where we down grade and see if that really helps.
Jacob


#19

Jacob, I sent you a PM. Thank you.


#20

I got my Bullet in January and it came with the IBST, but anyway, I contacted Aillio on Sunday May 12 and today Wednesday 15 I got a new IBST on the mail, I installed it and my roaster now is letting me preheat up to 590F. I have to say, superb service by Aillio, thank you Toni and Yau, they even sent me extra cables just in case. I’m planning to do a roasting session tonight ( of course I couldn’t wait until tomorrow) and I’ll let you guys know. Thanks to every body who reply with information for the community.