How to update Roast time right the first time?


#1

Hello, I know there is some info on this, but is there a workflow somewhere that I can follow? I would like to get from 2.20 to 2.5, but would like to do it with as little as hassle as possible. Any hel would be appreciated. Thanks! -Marc


#2

Well, if any help is ok, I’ll offer what I can. Just so you’re aware, I use a Win 10 laptop.

  • Go to GitHub to find the current offerings. I think you should be able to drill down to find at least some earlier releases.
  • Most recent release seems to be first in the list; currently (31 Aug) that’s RT 2.5.0-stable. You can also find the earlier 2.5.1-alpha.
  • D/l to a place you’ll be able to locate again.
  • After the d/l finishes go to that location and…
  • Double-click the file.
  • RT will install over the top of your current version.

I’ve been able to go forward or backward with RT versions; the process has worked for me either direction. At this point I have a fairly complete inventory of prior versions back to 2.2.0-prod and have re-install all of them at one time or another. I think that means others should also be able to go back to 2.2.0 if needed.

Since you’re using 2.2.0 already, that means your drivers are working and that resolves the more troubling issues.

I’m using f/w 523-beta. Not sure what errors in my description here would creep in with earlier f/w releases (hopefully none). If you haven’t already, you should consider going to at least the f/w load that lets you calibrate exhaust fan speed (sorry, don’t recall the ID).

If you expect the current ‘stable’ release of RT to be ‘perfect’, i.e. error free with all the final bells & whistles, you may be disappointed… stable, remember, means it probably won’t crash.

It’s been too long since I used 2.2.0 to be certain, but as I recall you should be pleased with what you see in 2.5.0-stable. Several new features like “Messages” (you’ll find change info here) and “Roast Settings” for choosing curve colors. Curve colors, however, has an issue where RoR and Exit Temp are reversed. They think they fixed it, but I still see a problem when viewing earlier charts on R.W. You have to be connected to the i’net for it to be successful.

Hope this is of help…

Bruce


#3

I’m planning my first real upgrade of RT, also, from 2.2.0 Beta to 2.5.0. Thanks for this help. Another feature that is newer than 2.2.0 is Recipes.

I’m still using f/w 512 from a May 2019 upgrade, which includes Fan calibration settings. I think I will upgrade the f/w after I’ve run RT 2.5.0 for a short while to try to isolate any issues, if they arise. Or should I do it in reverse?


#4

Just my personal preference but, since f/w controls everything, I’d want that out of the way first in case some s/w behavior relies on a f/w feature.

Bruce


#5

Good point. Thanks.


#6

Bab, thanks for the write up on updating. I will be trying this out today and will report back how it went. -Marc


#7

Well, that was easy. Now to see how it runs this week. Thanks again. -Marc


#8

Well I just completed my 1st two roasts using RT 2.5.0 stable. Went well.

Notes. while my roaster is cooling:

  1. I saw the mistake in labeling the lines in the Legend while roasting. The labels are reversed for the IR Temp and the Bean temp. They are correct on the right side of viewing the roast once complete.

  2. During my 2nd roast, the Info panel did not increment my Roast number, instead it had the erroneous info we have seen before in Serial Number, Firmware Number, and Roast number.

  3. Small thing, but after I opened Messages and looked at release notes, I couldn’t find a “Back” button, or an “X” at the top right of the window to x-out/exit. I’m spoiled. I just hit the “Escape” button on the keyboard.

  4. I like the new features, and look forward to trying Recipes.

Thanks, Aillio!


#9
  1. Forgot to look at that yesterday… dunno how mine is labeled. Sorry. I meant to check that.

  2. The bad data in Info seems to be related to improper initializaion of f/w. I’ve been able to correct it by cycling the power, but there’s been several reports here of scrambled Info data that suggest the issue is a corrupt f/w install. Dunno for sure, but I have taken to checking Info before Pre-heating, then cycling power if necessary (unplug power then reconnect). It has happened more than once. The USB port apparently has not been an issue for me.

  3. Esc seems to be the only way out of Messages.

  4. Have fun with Recipes. I think I like fiddling with the controls and have decided to give it a pass.

Bruce


#10

Thanks for info. I remembered reading about the f/w issue and needing to reboot without USB, so did that last week when updating the f/w…then did two roasts with all working well…so then yesterday upgraded RT to 2.5.0 and the Info panel continued with correct info on 1st roast, but not second roast.

I fully expect the Info panel to be correct when I roast again. Just seems strange that those last 3 measures get corrupted.


#11

Roast # & S/N are saved data in the Control Panel. Seems like it would almost have to be a read error in that h/w. Not obvious to me why it would get read again after initializing.

And in that vein, I don’t recall seeing the S/N or Roast # corrupted after getting f/w running without that error, but I have to admit I haven’t expected it and may well have overlooked it. I’d hate to think we have to continuously check that for fear of f/w being modified. Especially since you can’t safely cycle the power once roasting.

Even if that error is creeping in, I can’t say that I’ve seen anything odd in Bullet operation once I start roasting. Operation seems solid to me.

Bit of a ramble… just thinking out loud which is not always productive.

Bruce


#12

Btw, I don’t see Roast # update during a roasting session yet it seems to have the total right. Anyone see something different? Not important, just curious.

Bruce