IBTS installed - stuck at firmware 448 - updating stays at 0 %


#1

I installed the IBTS and according to the guide the last step to do is upgrade the firmware

the firmware upgrade is failing. Its just sits there doing nothing - it says updating firmware 0 % and just stays there. Have retried an retried, waited for as long as 30 minutes. just stays at 0 %

See screenshot: https://1drv.ms/u/s!AmfhRvQRPMkdl7EPzNe3iNZbwloDbw

I tried different USB cables, different computers. So whats wrong? is the firmware server down er something?

I am at firmware 448 using roasttime 2.1.0 beta.


#2

After hours of troubleshooting with no real progress - seems I tried everything, reinstalling USB drivers, reinstalling software, different cables, different computers etc. - i switched to roasttime 1.x and voila firmware update ran succesfull first time.

There must be some bug in roast time 2.x as I used same PC, USB cable etc. Only difference was roast time 1.x vs 2.x

I noticed, that when the Bullet enters firmware mode (full fan, 4 beeps(?)) the device manager shows a new serial device (COM5 in my PC) that could not start, drivers for this device are fine) I guess this serial device, 9600 baud etc. is for the firmware communication?

Hopefully we dont have to switch to roasttime 1.x everytime we need to firmware update - it is tedious swiching USB drivers etc. :slight_smile:


#3

Hey,

Thanks for the detailed info. I haven’t seen anyone else encountering this - but I will look into it this week and try to get it sorted for you.


#4

I just checked out some of your sessions, it looks like you never made it to this stage:

Is that correct? That would indicate something with the network request to fetch the BIN is off. Do you have any firewalls or anything?

Thanks!


#5

As I recall I never made it that far

I am using a local installed firewall on each PC - with a custom ruleset, mening that new applications that need internet access is followded by a popup notification on the screen that I either allow or disallow.

The software never popped up a notification - this could be either that for update software never requested internet access or the update software is calling some other application that I have blocked? I might find som info in the firewall log.

Next update, I will disable the firewall to see if this is the culprit


#6

Having a similar issue.
Installed new sensor. Downloaded 2.0.8, then it said there was an update to 2.2.0 so I did that. Then I went to update firmware. It said Current firmware was 13591 or something like that and two were available, 475 stable or 448 beta. I picked 475 and it showed the screen dialog ready to update. I did that and after a good 20 minutes the display shows 0% progress. When I clicked the Update button, the Bullet fans spin up and some beeps I believe.

What is my next move?

By the way, I noticed that The RoastTime shows the Roaster is unplugged (It isn’t and hadn’t been disturbed). In RoastTime I quit the update process, quit roasttime and restarted, when then suggested I unplug and re-plug the USB. Didn’t work. COntrol Panel shows BT 24 TIME Off DT160 and fans going fast.
frustrating…

edit, I read some post which suggested using the Force Driver Update, which I did. I re-tried to update firmware. Roaster showed disconnected as soon as it began, but then showed it connected, and there is progress with the installation. Says successful! Yay!

I’ll post a new thread or contact support if I have further problems.


Updating firmware problems (firewall related?)
#7

@matthew

A follow up to recent post regarding firmware update troubles. Still having major problems updating firmware, and it’s frustrating, so roast time developers please help out :slight_smile:

It might be firewall related and it might not be – I need help finding out.

So far, here’s what I know
• Roast time 1.x updates with no problems; so, hardware, cables etc. is fine.
• Firewall settings are fine as well when Roast time 1.x is allowed through

So basically, I am only changing roast time to 2.x and updating USB drivers and allowing roast time 2.x to pass the firewall in the exact same manner as roast time 1.x (basically just full access – any to any from any)

Then this happens when Running roast time 2.2.0 beta. (or the other roast time 2.x releases)

• Trying to update to firmware 507
• Roast time 2.x refuses to update firmware, never successfully updated the firmware
• The Bullet enters update mode, and I see/hear windows detecting new USB hardware
• Firmware never downloads, it is always stuck at 0 % - never moves.
• What I think I was supposed to see, was the update bar go from 0 % to 100 % and the firmware updating – update bar just stays at 0 %
• Roasttime.exe 2.2.0 beta is allowed through Comodo Internet firewall. I never see it blocked in the log
• Allowing manually or automatically through firewall does nothing
• Reboots etc. does nothing

I am not sure it is firewall related, even though it was suggested by Matthew. I can’t say for sure it is not firewall related. Are you using some internal windows services to update or is it the roast time.exe that downloads the firmware?

Please help me with what I have to keep an eye on. I am an educated programmer and network/infrastructure specialist, even though I haven’t practiced this for 10-20 years – just to let you know, I think we can solve this together, so no need to be gentle :slight_smile:


#8

So, Comodo firewall removed. Running plain windows 10 without any other apps installed. Still refuses to update.

Screenshot, stops here every time: https://1drv.ms/u/s!AmfhRvQRPMkdl7YUq_aBRrSK1V8qZg

It is not an option for me, again spending hours with the tedious task of reinstalling roast time 1.x and reinstalling USB drivers (which is no easy walk here either, taking hours of troubleshooting), just to be able to firmware update the Bullet.

So, I would like to be on roast time 2.x. Please help fix the auto update. Or maybe there is some way I can update manually? Right now, the roaster is a brick, stuck in update mode.

Please advise.


#9

This looks like a driver issue not a firewall problem - your screenshot shows the bullet is “not connected” so there’s no way it can continue with the firmware update any more than it could if you unplugged the machines. Roast v1 and v2 don’t play together due to the difference in the USB drivers as far as I know. I recall there was an article on here from Jacob in how to clean house of the drivers and reinstall them. I’ve had no problems with firmware updates using Windows 10 and Roast v2.2 so there shouldn’t be any need to keep v1 around for updates.

I’ll leave the actual advice to the Aillio dev(s) - that’s just my suggestion based on your symptoms so far…my usual OS platform is a Mac because Windows driver issues are such fun but I have a spare Dell laptop knocking around that I just keep plugged in for roasting operations…


#10

Bullet was connected working absolutely fine, but when you hit that update button the Bullet enter firmware update mode and is then not connected anymore. What happens is the USB Bullet name (BulletFS-something) changes to serial device (com5). Happened again this time, and when this happens once, the Bullet is stuck in firmware update mode and will show disconnected in roast time no matter what…

Aillio, if it should show as connected in windows, when in firmware update mode, please let me know, as this then might be the problem.


#11

You may be right, I honestly can’t recall whether the Bullet showed disconnected during the update when I ran mine. I don’t play an Aillio developer on TV or at parties either :wink:

I would still honestly look for the article on the clean driver reinstall, that looks way more likely than a firewall problem given that it looks like you actually did get the firmware package downloaded to your PC. But it’s easy to make suggestions from the sidelines…


#12

More troubleshooting.

Created a new profile in windows. Admin type account. No reminiscence of roast time. Reinstalled roast time 2.2.0 beta. USB drivers reinstalled. Still same problem. Update stays at 0 %

I am out of ideas, other than to go down that dreary roast time 1.x route – I could, to make everything fine again and to prove the point again (hardware, software, USB cable etc., is fine), but it will only hold to next firmware update. So, please advise.


#13

Thank you for your suggestions. Drivers are reinstalled several times… according to the article.


#14

I have seen others struggle with this as well


#15

Ok, so this is what is happening.

The drivers are installed for the main firmware, but when you go to update mode (in bootloader) then the PID (Product ID) of the USB is different, due to the fact that we got our own PID after we shipped the bullets out. So, when it enters bootloader mode then the drivers are not installed, as it sees a different device.
To solve this, while in bootloader mode (with the fans going at full power), close RT, then restart it again and press force update drivers. This will install the drivers for the bootloader PID. Then proceed to update firmware as you would normally.


#16

Jacob, thank you, will give it a go :slight_smile:


#17

Succes!

Updated succesfully.

Thank you!


#18

See I knew an expert would be along shortly to get you home safely :wink: And they explained the magic too :slight_smile: