Max preheat stuck at 205°C?


#21

You can see the IR fan running if you leave the control panel off. Make sure everything is connected, and just plug everything in and give it a go. If the Info panel doesn’t see the fan, then the controller that restricts the pre-heat temp to 205 won’t see it either. I had a badly soldered pin on the IBTS controller. (I posted photos of that in a previous thread. I will find those and link) I also got help from Aillio support (they were great) to test the board with a multi-meter to see if power was getting to the fan (it was not)


#22

Here’s a link to a Google Photo album with a couple of images of the PCB. Since I resoldered that pin (actually, a friend did it. I don’t have the manual dexterity) the roaster has been working perfectly.


#23

Excellent! The pushed-back pin is very obvious in the side view. Thanks for that.

Bruce


#24

Many thanks for the photos. Sadly, my pins seem to be in place. I also did a ‘smoke test’ and the fan definitely is spinning (pulling cool air in from outside - I’m assuming that it is for cooling the IR sensor and that is the correct direction). For some reason, the fan is not being detected. Looks like time to dig deeper with Aillio support.

b


#25

All, here’s what I submitted to Aillio support - if anyone has other ideas, I’m all ears.

"My R1 is failing to detect the IR cooling fan. The fan is running - I can hear it and a ‘smoke test’ showed air movement - but the ‘i’ window shows 0 RPM. All other fans are detected. As a result, preheat will only go to 205C, and roaster throws ErC002 error when bean temp hits 205C. Roaster worked ok for a couple roasts a few months back but failed and nothing I’ve tried from Roast World forum will fix it. Problem occurs whether connected to a PC or run stand alone.

Some things I’ve tried: checked 5-pin connector with 2 wires and pins seem ok; cycled firmware between versions hoping to fix a bad load; forced driver update in case a PC software update wiped something out; swapped USB cables in case poor quality cable was causing issues.

More info: US R1 purchased earlier this year with a Feb 2018 build date on the board; running FW 512 (roaster confirms this on startup) and RoasTime 2.2.0; using 64-bit Dell laptop running Windows 10."


#26

Things to check, in my experience:

There are many fans - make sure you know which one is the IR sensor fan - it’s by far the highest pitch (even higher-pitch than an angry bee).

The connector seems to have both power and a sensor, so it’s possible for it to be spinning, but not detected as spinning, so when it’s not detected, take everything apart (yeah, it’s a pain!) and remove and reseat the connector a couple times. I added some “contact cleaner/enhancer” to try to avoid intermittent connections, which seems to help.

Occasionally, even when everything is working, it won’t detect the fan, but unplugging and re-plugging in the Bullet kicks it and helps it recognize the fan.

Finally, I’ve noticed that sometimes preheat will register as completing way earlier than normal (in my case preheat to 300°C takes about 15 minutes, so if it’s earlier than 10 minutes), and when this happens the IBTS is wrong (have ruined roasts), so I have to reboot the Bullet again.

All the above said, lately, it’s been working pretty well for me lately. - here’s yesterday: https://roast.world/my/roasts/kt0D13bxNPH7NZRGK2JAe


#27

Thanks Dylan. Question about the fan(s) … I’m assuming the IR fan is behind the PC board and is the only one in the front panel … Are their any other fans in that area? Maybe what I think is the IR fan is something else :thinking:

I’ve removed and reconnected what I think is the right connector once (from dpiette’s photos). Am I right that it is the 5-pin with only 2 wires attached? Did you find you had to disconnect multiple connectors or just that one?

Appreciate all the help from you and others on this forum.

Cheers,
Bill


#28

And thanks for the roast profile. For comparison, with 500g it takes me almost 3 times as long to get to FC as your roast due to the low PH temp. I’m going back and forth between the R1 and my old Hottop to roast until I can get this sorted out.

B


#29

Oh - and I can’t count … 6-pin / 3 wire connector.

b


#30

Yes, it’s the only one behind the PC board. However, it sounds like you’re not checking all of its connectors. Here’s the photo from the installation guide - it’s got two connectors, one with three and one with four connectors. It’s worth reseating both of them, I think.


#31

You read my mind … got it pulled apart exactly like that now and I’ve chased the harness back all the way to the actual fan. Fan is spinning but not detected. I don’t have any Stabilant or other connector enhancer but disconnect/reconnect didn’t solve it.

Thanks for the help. Looks like it’s deeper than I can handle as a tinkerer.

Bill


#32

So here’s the latest …

With thanks to Matt at Aillio, the current guess is that my IBTS unit is bad.
Following all the connection checks, Matt asked me to load up RT 2.4.0 and run the pre-heat mode for several minutes. Turns out RT 2.4 delivers more info to Aillio than earlier version and, with your S/N, they can pull data and diagnose from that upload (hope they didn’t also hear my wife giving me a hard time for farting around with my coffee roaster for several days!).

What Matt saw was no sign of the IBTS fan (even though it is getting power to run).

Matt put me in touch with Julio at SM to get a replacement IBTS unit. Hopefully will have the replacement very shortly to test. If that doesn’t solve it, PCB is next :worried:

Bill


#33

Hi Bill,

Wondering if you received the replacement IBTS unit and if your problem was fixed. I’m running 523B and 2.5.1A and had a similar issue tonight when I started PH. Noticed it would only go to 205 C, tried changing the PH from the PCB but the option would only go to 205. I’ll check the connections tomorrow and check to see if the PCB fan is running. Maybe I need to revert back to 2.4. Anything you can share would be appreciated. Thanks, Teddy


#34

Teddy,

As of today, looks like my problem is fixed. SM sent me a new set of boards for the control unit. First try was to replace the IBTS but that actually made it worse - the initial problem was the IBTS fan was spinning, but not recognized. When I installed the new IBTS, the fan wouldn’t even power up.

Originally SM was going to send just the LED board, but then decided to send the full unit. Took me about 2min to install and everything worked great. Pre-heated to 255C, dropped at just over 205C BT and no temp errors or annoying alarms.

So if you are having the same pre-heat issue, first check if the fan is spinning (you can hear it through the bean input chute). If it is spinning, then check the ‘i’ menu on RoasTime - if it shows 0 rpm on the IBTS fan reading, my guess is you have the same problem I did.

Good luck!

Bill


#35

Also should add, I tried all sorts of firmware, software and driver updates but none of that helped.

b


#36

Glad you got it solved. Was this a new Bullet or an IBTS upgrade you made yourself?


#37

Brand new as of earlier this year. I was lucky enough to get one from Sweet Maria’s Jan shipment. Having come from a Hottop, I didn’t realize that the Bullet wasn’t performing up to snuff. But after reading some of the posts here, I realized I had an issue and pinged Aillio. They read the data log and confirmed there was a probem.

Bill