New Bullet R1 V2 RoasTime/Driver Install Issues

I had the following issues with a brand new Bullet R1 V2:
-Roaster Disconnected (red dot) status after driver and latest (3.2.3) RoasTime software installation

  • same result on a separate laptop ( both using Win 10 pro)
  • two listings for Bullet in Device Manager, one with exclamation point (trouble device)
    -using supplied USB cable (and other ultra high quality cable for comparison)

Solved issue by uninstalling all drivers and software ( in Win 10 Device Manager and Control Panel) , installing old V2.5.5 software ( and then installing v3.2.3 on top of 2.5.5. All works now!

Aillio was most helpful - I wrote tech support and they actually called me from Taiwan in a couple hours after the initial email and helped with the solution! Very good sign regarding a new device.

Hope this helps other new Bullet owners!

1 Like

Thanks for your feedback. I wonder why those drivers were there in the first place. Glad you got it solved!

1 Like

I think I have seen something similar when I had some Arduino or Adafruit device drivers which used the same ST microcontroller as the R1 adding it as a spurious USB device. I just removed the “fake” R1 in Device Mangler (sic). Eventually uninstalled the competing device driver as no longer needed. The Zadig utility which has been mentioned here a couple of times is very useful….