New roaster, connection issue

Just unboxed and hooked up to my 2013 MacBook, running 3.2.3.
Roaster was connected. Green light.
Updated firmware, (probably should not have)
Now I cannot get roaster to connect. Red light.
Searched this forum, tried using a Windows machine, same result.
Tried version 2.5.5
This one I couldn’t even sign in, it wouldn’t accept my credentials.
Also it did not show roaster connected.
Tried putting it in manual bootloader mode. No dice. I got 3 beeps and no connection.
I’ve submitted a support ticket because I’m at the end of things to try.

F/W update requires a power off cycle that is more than perhaps 10 seconds (no it doesn’t say that anywhere but the power source in the Bullet takes awhile to decay from power off). And it also requires disconnecting and reconnecting the USB.

If you think you did those things then it may be time to start a Trouble Ticket with Aillio Support. It’s 1730 here in AZ and the folks in Taiwan are just about getting to work now so it’s a good time to catch someone.


Thanks for the info. I did do those things, learned on here. Ticket submitted.
Appreciate the reply

If your roaster is in bootloader - the light will either be red or yellow. You should still be able to run through the firmware update process even with the red light as long as you verified the roaster is connected in the OS.

To clarify, the light I’m referring to is the software connection indicator in Roastime bottom left. I did try to update originally when I had a connection and I thought it worked. The percent indicator filled up and then I was prompted to reconnect… If I try to update now, it skips the percent filling up, and tells me to restart the roaster. Which I did.
None of this fixed my connection to Roastime.

Issue resolved.
I have a brand new Bullet with a new PCB running firmware newer than the latest stable release. When I updated the firmware to latest stable release, it stopped working because apparently my board isn’t compatible with older releases than it shipped with. By installing the beta I was able to restore connection.


Not sure how to read this - you had another device other than the R1 plugged in when you were trying to update the R1 firmware and that was the cause ? What was the “PCB” ?

No he had a new bullet and accidentally downgrade the FW to a version that does not work with his hardware. We have since made this impossible to do.