Not synching with Roast.World?

After clicking on the link in the recent email to “reset password” to enable a single log-in, the Allio program will no longer synch with Roast.World. Any workaround for this?

I had a similar problem, so I logged out of my account because I thought that would help. However, now I can’t log-in to my account and can only roast as a guest user.

This is concerning - looks like since the new account thing was implemented, the Mac version of the app is now broken (e.g. you can’t roast as your user on the site). I was just about to do a roast, now my roast data won’t save to, and I was using that to keep track of inventory.

Just curious whether the folks at Aillio are going to do anything about this… Jacob, anyone??

1 Like

Are you on version 2.0?

I can not enter into the account too. So my roast data won’t save to
My mac version is updated to the new one.

I checked for an update when the problem was happening, but it was not yet available. I received an email just this morning about the update. Will try tonight when I get home.

I just downloaded 2.0.0 and installed, but at the log-in screen my password was not accepted and the “reset password” button is not working

I didn’t know there was a 2.0.0 version of Mac app until I got an email this morning. Unfortunately, I needed to do my roasting for the week yesterday, so I just did it under the “Guest” account on the old version of the app… hopefully, there’s a way to export those, or I guess I’ll just adjust my bean inventory appropriately. :expressionless:

On a positive note, the new app looks really nice - I’m looking forward to roasting with it in a few days. Note that I’m able to log in with my new Aillio user account. Thanks!

1 Like

Not only will this release not sync with my account - I’ll be roasting today as Guest - the firmware drop-down announces that there are no updated firmware. The chance to update to Beta 444 just doesn’t happen. Come on guys, the hardware is pretty exceptional, but the software / firmware development is amateur hour.

Okay everyone, the new Mac update does work, and the firmware is available and installs fine. A couple of hints for those trying to update…
It appears that if you use the Mac “Keychain” feature to load your passwords, that won’t work… so I hope you remember your password. I didn’t, and tried to reset my password, but that didn’t work either. I finally found (remembered) one of my passwords that worked, and I got in. Once in, you can update the firmware from the Roast.Time software. Then you can roast. My previous roast profiles were also there. Here are a couple of problems I encountered…
The new software looks really nice. The layout is better and the controls are better. At the end of the roast, naming the roast is okay, but selecting your beans does not work. Also in the new software I can’t find any way to print the graph (I’m old fashioned and like to print the graphs to study). The workaround for updating your roast is to go to Roast.World and select your latest roast and then update it there. There you can select the bean you roasted and update other parameters.
On my next roast I will try to be more careful to document things that might be improved or changed and provide feedback. Thanks everyone!

In other words, something here doesn’t work sensibly. Many if not most Mac users use Keychain, rather than using easily cracked passwords or keeping a written record of the passwords lying around… A release which doesn’t accommodate routine apps or OS functions, like Keychain, was not tested enough to be released, even as a beta.


Okay, I’m up and running (finally) having lost roast data for my most recent roasts. The new software looks very nice and I was able to update my firmware. Lack of support for Keychain is still the pits.

I was able to update to 2.0. My previous roasts are showing in the new software except the roasts do not indicate the bean roasted. When I try to update the roast to specify the bean roasted, the data is not saved.

V.2.0.1 addressed the bean selection issue. As an FYI, the auto update didn’t work, so I simply did a manual update to get v.2.0.1 running.

Hi every one,
Where can I find the new 2.0 mac version? I only find the 1.12 version on Aillio website.

Since this a completely new app you have to copy the password from Keychain into RoasTime. RoasTime remembers the password after that, so you only need to do this once.

Thanks for the kind words.
Since this is a new app you will have to copy the password from Keychain manually the first time.
We are working on fixing the bean selection issue.

1 Like

The New UI is very beautiful~
But… when I key in the account and password and put enter (or Login), It does not work~
I can only use as guest~Thanks you

So I updated to V.2.0.1 of the software, but I did a roasts on the old roasttime before the 2.0.0 release.
The data is accessible on the 1.1.3 software, but not the 2.0.1.
How do I add the roasts into the new software? I haven’t deleted anything.

I wanted to keep track of all my roasts.


If I understand this post, the 2.0.0 will automatically update to 2.0.1 “after some time in the application.” I have had the application open for several hours and no update. I turned on the Bullet Roaster thinking that perhaps the unit must be on. It has been another couple of hours, and still no update. Can you please provide some additional detail as to how to get this update?

Hey Jeff,

Did you reset your password that migrated to the new “Aillio ID” system? Are you getting an error about the account not existing or is nothing happening?