OSX 2.1.0 Beta Release


#1

Hey Guys!

Thank you all the “lab rats” that helped me test out the USB build fixes. Everyone seemed to be cool, so today I am officially releasing the beta version (again). You may update from your application or you can manually download it here:

https://github.com/roastworld/roast-time/releases/download/darwin-x64-prod-v2.1.0-beta/RoasTime-2.1.0-beta.dmg

Starting from this version, you will only receive update notifications if you are opted in to the “channel”:

Please remember that we expect some bugs in these betas and rely on your feedback to help improve the product. I appreciate all of you guys. Windows will be coming soon!

Thanks!


OSX Lab Rats Needed
#2

Is there a document that explains what is new a different in the beta version? It would be nice to be able to make an informed decision whether or not to use it. As a new person to this whole thing, I generally want the most stable platform (software and firmware) that will work with the features of my v1.5 hardware. (There’s no use in going back to a “stable” release that doesn’t allow the use of the IBTS, for instance.)

How will the numbering work for the firmware? I was using the latest stable release (448), but found out that it didn’t work with the IBTS. Now, I’m on 475, which is apparently a beta.

Here is where I’ll make my pitch (AGAIN) for a single location where one can find out all the existing versions of the hardware, how to tell which you have, what firmware is required for each, and what software will be compatible and provide what features.

It has taken me 3 weeks to cobble together a working roaster (at least I think it’s working). This was all due to incomplete or conflicting tidbits of information floating around on the Aillio site, the GitHub site, this forum, and the few sheets of paper I got with the roaster about hardware, firmware, and software versions and options.

I’m a software/firmware guy - I know how difficult it is to get it all working. But, I know you can do better.


#3

Hey,

As of right now, the best place to get information about RT software is from here:

https://community.roast.world/t/roastime-release-log/797/21

But you are completely correct and this is definitely NOT a solution. I have tried my best to consolidate information into the community here, but we have not had a chance to create a single source of truth as of yet. It IS on the roadmap though. Until recently, we haven’t had much structure in this area as far as releases or anything extremely stable. It has been my priority to try to stabilize everything while also adding features.

So again, sorry about this and we will definitely get this solved soon!


#5

My software just updated itself from 2.0.6 stable to 2.1.0 Beta, without asking if I wanted to, or telling me it what was happening. I am NOT opted in to the Beta release channel. I haven’t roasted since early December 12, 2018.

If anyone can explain to me what might be going on, I’d appreciate it.

Thanks!


#6

HI there, My Mac isn’t recognizing when it is connected to the bullet.
I’m using the latest MacOs Software on a MacBook Pro (13-inch, 2017, Two Thunderbolt 3 ports).

I’ve uninstalled, reinstalled, tried a variety of startup configs - plugin in then start, start then plug-in, etc.

I think it may be something with the bullet board not outputting? Is there any way to reset things on the board?

Any other reasons why Roast-Time won’t recognize being connected?

I just got the bullet in Jan and haven’t been able to use RT with even a single batch yet.

Thanks for any help you can give!


#7

I think the opt in thing is new in 2.1.0 so if you had an earlier version it would just update without asking. Now that you are on 2.1.0 you can opt out.


#8

How are you connecting the bullet? Through an adapter of some kind? or an USB C to USB micro cable?


#9

USB-C through adapter to USB-Micro (included with Bullet).


#10

I feel somewhat the same as celticcupcoffee. I am a new owner of a 1.5. Information is somewhat scattered. Aillio has been doing a great in responding to user questions and comments.

I may be inventing a new word, but it would be great if Aillio could also be (Presponsive). Like anticipating issues users might have, and speaking to those issues up front. I knew going in that this would be a mission, and that is just fine. A bit more easily reachable support would be real nice.


#11

I talked to Jacob and we are going to put some energy into getting this all consolidated. Thanks for bearing with us though.


#12

Hey,

Can you type ioreg -p IOUSB in the terminal while the bullet is connected and screenshot it for me?

Thanks!


#13

I just did my first roast with mac RT 2.10 mac beta.
RT now displays IRBT on the left. My roast was Ethiopia Decaf 756 g. At the beginning of the roast, the BT display on the roaster, and the IRBT in roasting matched exactly. Yes!
But also in the early roast, the BT on the upper right of the display didn’t match properly.

Later in the roast, Roaster BT and RT IRBT no longer were the same and differed by quite a bit. See images below.

Lastly, I was unable to hear FC. This has been common in my decaf roasts. Thus I was unable to mark beginning of FC in RT. Yet RT still displayed the development ratio. I don’t understand how I can be given the ratio without RT knowing when FC started.


the two images above were taken within 3 seconds of each other.


#14

Here’s what I’ve got.


#15

That is quite odd. Let me talk to Jacob about the firmware and see what went wrong here.


#16

Hey,

It looks like the roaster isn’t being picked up from the USB. It should show up like this:

Do you have another USB cable to try?


#17

I think your Bullet is showing the bean probe in the display.
If you use Firmware 475, then the top left button will toggle between IBTS and the bean probe. The LED light to the left of the display will be ON when it is the IBTS.
Please note that the Bullet display rounds down the number, so if it is 191.9 it will still show as 191.


#18

Thanks much for your reply. I’ll try this at my next roast. Can Aillio also try this and confirm that this is true?


#19

Yes, I’ve tried one other cable. I really think it’s something in the board. Is there any way to test that theory, rest something, or fix it? Thanks!


Instagram: fireweedcoffeeco


#20

your advertisement , what do you roast commercially with the R1 ?


#21

If you could find someone with another laptop or mac to try it on that would be helpful. The USB is tested from the factory, and we have never seen a USB connection be damaged so it seems unlikely - but of course not impossible.
If you connect it to a windows computer it should show up in the device manager.