OSX 2.1.0 Beta Release


Thanks much for your reply. I’ll try this at my next roast. Can Aillio also try this and confirm that this is true?


Yes, I’ve tried one other cable. I really think it’s something in the board. Is there any way to test that theory, rest something, or fix it? Thanks!

Instagram: fireweedcoffeeco


your advertisement , what do you roast commercially with the R1 ?


If you could find someone with another laptop or mac to try it on that would be helpful. The USB is tested from the factory, and we have never seen a USB connection be damaged so it seems unlikely - but of course not impossible.
If you connect it to a windows computer it should show up in the device manager.


No luck. Tried an older macbook pro that works reliably well. Same response. I tried a couple different usb cables with that one as well. What else can I do? Thanks for your help.


Ah! That’s a bummer. Do you have a windows machine? That may be something to try. Theoretically, if it works on windows, than there is likely some OS related issue blocking the USB. If not, I will have to leave you in @jacob’s capable hands for hardware!


Ok. Thanks. I will see if I can get my hands on a Windows machine but it seems like it should work with the latest MacOS? Are others on Mac running 10.14.3 having any problems?


Not that I have heard. But in the beginning if last year we had some issues with OSX claiming our USB devices before we could. This issue has been solved since, but I wouldn’t rule out something like this completely in your case if it is something easy enough for you to get your hands on.


I powered down the Mac, held down Shift, Control, and Alt and the power button all at the same time and released at the same time. I then powered up the Mac as usual and the RT was able to recognize my Bullet.
Hope this helps.


Just following up. I still have no recognition of the bullet to my software. Who should I contact about getting support for the hardware/board on the bullet? It’s never worked me so I’m hoping that someone from Ailio can help me.



did you get your hands on a PC to see if that can recognize the hardware?


Jacob - I finally got my hands on a PC! I can’t believe it took me this long but apparently I don’t know many folks with PC laptops laying around.

I can now confirm that on a relatively new Windows PC and 2 Different MacBooks (5 years apart) do not recognize the roaster. I’ve tried numerous USB cables, updating software, etc. I’m getting nothing.

I think it’s something with the board itself. Is it something that can be fixed or replaced? It hasn’t worked since I got it in January and it’s really disappointing considering how much I roast and how much logging I’ve lost (20-30 pounds a week).

Can you help me?

Thank you!


With Windows Device Manager you should be able to see the Bullett in the Usb devices list. Also plugging and unplugging the usb cable should make a Windows System sound generally.

Anything there?


Zilch. Wish I was getting something.


Well Windows can make software look like hardware - what Windows version ? 10 ? 7 ?

I would start verifying the USB on the laptop by plugging in a thumb drive or something, then the cable you are using with the R1 but plugged into something else USB so you can verify the cable.

Daft as it may sound, are you plugging into the USB on the rear of the control panel or the one on the bottom designed for the led light bar ? I’ve known people do that so no harm no foul.

If all of that looks good, the other problem I have seen with other pieces of kit is that the moulding on the plug at the mini USB side is too fat to clear the housing and allow a good USB connection so if you feel comfortable removing the control panel faceplate I would try plugging the USB direct into the board so you can see you got a good physical connection.

Also if you are using RoasTime 2.0, try doing a “force driver update” from the Tools menu.

If non of that pans out, I’m sorry my bag of tricks is empty and I will let the pros take over…

Fingers crossed it’s something damn silly. It usually is if it’s not damned obscure in my experience :wink:



Stuart - I appreciate your persistence here.

It was a pretty new windows 10 machine. Not my own (I have a MacBook Pro that I was never able to get to connect).

Beyond that - plugging in behind the panel as opposed to the light bar.

I didn’t try removing the panel, that is a good suggestion. I did try a couple different cables and one definitely “clicked.”

I think that machine had four ports - I tried three of them.

I didn’t try the force update but I just installed the software right before testing (yesterday) so hopefully that was what should be working.

The reality is that over 4 months three different machines and multiple cables, etc. it has never connected. So I think the issue is with the hardware itself. I’m hoping to get this resolved sooner rather than later.

Thanks again.


I don’t speak Mac, so if you still have access to the Win device I have one last thought…

When you d/l’ed the Windows version of RT s/w, you did choose the x64 version, right? Iirc, that version of the installation package will install the drivers as part of RoasTime installation. As I understand it, the x32 version requires separate driver installation. Dunno if the drivers are the same or different.

This is a link to current Win s/w that I have confidence in:
RoasTime s/w on GitHub

Choose the x64 version.



RoastTime v1 required separate driver download - you’re right I believe the installation of v2 incorporated a driver installation but Jacob has said that sometimes can go south which is why there is the option in the Tools menu to force the driver install manually. If you haven’t already tried that I would.

Other than that, being the curious tinkerer that I am, I would open up the faceplate and look at the circuit board around the USB connector, it’s possible it’s a bad solder joint which would be fairly obvious. But as you’re still within warranty (assuming you got it new in Feb) I can understand you’d want to stay hands off - I don’t think Aillio would claim you broke it by taking a look but I’m not affiliated with them in any way, just trying to help out a fellow owner.


Ah, yes… all the bits I couldn’t recall. Thanks for that.

I take it you don’t recall anything about different drivers for 64-bit processing vs. 32-bit processing… ?? Typical for me, mine worked so I made no effort to retain all the details. Mea culpa!



Hey all, Just as a follow up. The good folks at Aillio sent me a replacement board and it is working fine, right out of the box with my Macbook Pro! I’m so excited to give Roast Time a spin and see how it can help me improve my roasting.

Thanks for all the help!