Please Help

Hi All
First of all , I’m not very good with computers so any help would be appreciated. I,ve avoided updating or changing anything so I didn’t run into problems like this. Yesterday I wanted to do some roasting and tried to start roast time and got an error message from Windows saying that roast time could not start and had to be redownloaded. I downloaded it and discovered a different roast time with a different graph and no settings button. I’m not sure how to tell which version or firmware I now have. I also changed my username slightly awhile ago. I’ve also lost all of my previous roasts .

Cheers Barry

start roasttime. It should just open up. At the top it should tell you if you’ve logged in and give you the email address the software is using.

on the left hand side you should see a cog icon. press that and the config dialog box will open. the first option is firmware/software.

next option is user which should give you an email address you log into roastworld to sync your roasts etc.

down the bottom of the config window is the community/help button. that should log you into Your browser may automatically allow you to log in. If not press the log in button at the top right hand side of the browser tab, next to the icon of the magnifying glass.

that should open a login window for the forum. Pretty much you can then start to find out anything you need from there. There’s also a forgotten password option within that login window.

hope this helps.

if you’ve changed your password and it doesn’t log you in automatically.

First off thanks for your reply. What you are describing seems like what I had before . What I have now doesn,t have the settings icon. What I redownloaded was a link on the error message from windows and I’m wondering if it’s roastime 2 . I started with roasttime 3 so i’m not sure. I think I will start from scratch and download roastime 3 to be sure I’ve got the right version.
Thanks again for your help
Cheers Barry

Problem solved. I had downloaded version 2 5 5 from the windows link. I downloaded version 3 3 0 and all “seems” to be fine. I got my roasts back except for the 3 I did on 2 5 5. Thanks again @sadler for your reply