Problem installing RoasTime 3 on windows 10 PC

Hi, downloaded the software V3.18 (64-bit) to install on windows 10. starting the software it says not connected to roaster. this is connected using the supplied USB cable. Tried to force the driver installation from within Roastime. Select the download folder and then nothing happens. It just sits on the dialog box. Nothing downloaded.

any help appreciated as i’m trying to do the seasoning roasts.


I ended up dowloading roastime 2.5.5 which installed a load of drivers. I then reinstalled roastime 3 and ensured the roaster was connected and powered up.

It connected and worked flawlessly.

hope this helps someone else.

1 Like

@sadler Thank you for posting this! I was running into the same issues with v3. Followed your instructions about downloading v2 and it worked!

Really pleased this helped. Thank you for letting me know. Much appreciated.

1 Like

this saved me as well! Thank you for figuring this out!

Hey @sadler - the driver install never popped up when you went through on the config? What location did you attempt to download them to?

i tried to default it to /downloads. it pulled up the dialog box to allow me to select the folder but having selected it the dialog box disappeared but no drivers were downloaded. Whereas, when i did the v2.5.5 install it went through a standard install and a cmd prompt console popped up showing the install. Wasn’t allowed to select a folder, it just did it. The moment i restarted v3 it just worked. Has done since and just now v3.1.9 was automaticallly installed.

hope this helps