Problems after attempting a firmware update

Hello dear community, I tried to update the bullet to the latest firmware version today. After I updated Roastime to version 3.3.0, the bullet should get its new stable firmware.

After the start, a red warning sign immediately jumped up at 1%, telling me that my bullet is no longer connected. Then all operating options are frozen. I’ve waited a while, but nothing has happened. The control panel of the Bullet was also no longer able to operate. So after a while of waiting, all I could do was unplug it from the mains.

After I restarted the Bullet there were several (6 I believe) loud beeps, but nothing appeared on the Bullet’s control panel. Everything was off, only the USB people lit up and the fan was on.
There is a constant red light flashing under the bullet where the electronics are located, which I never noticed before.

I then reconnected the Bullet to my Mac (until then I never had any problems with the software) and tried to restart the update. Roastime recognized the bullet and started the update. However, it always stays at 1%, even after over an hour.
the current firmware on my bullet is “unreadeble”.

A walktrough via an “updating manual bootloader” following the video instructions from Aillio was unfortunately unsuccessful. Here, too, the update bar gets stuck at 1%. An attempt with a Windows notebook also failed. Because here I have the problem that the bullet is recognized in the device manager, but no driver is installed. Even if you try to force the driver via RoasTime, it is unsuccessful. I’m slowly desperate. Do you have an idea?

I ran into the same situation yesterday. Only solution was to download RoasTime 2.5 and update firmware, which then went flawlessly (I used 602). I was able to do back to back roasts on 2.5 paired with 602 with the only caveat that roast.world won’t work (can’t login either). Despite that caveat, I am gonna wait until RoasTime 3.3 is solid before switching over to it as at least I can roast predictably now.

If it beeps at startup then it is already in bootloader mode.
If you are on windows then please check your device manager and see if the Bullet pops up in the bottom of the list under USB Serial Bus devices - post this screenshot.
If it does not show up, then try installing the driver again.

I am very grateful to you for this tip. I have done exactly the same now and the bullet is running right now. At least I can roast first. But how do we get back to the 3.3.0 version now?

Glad that you got up and going! As for 3.3, it’s clearly not ready for production use, despite its “release candidate” status. I think we ought to wait for the 3.3 stable release when its available via this link: https://downloads.aillio.com.

Link above is for RT2. The link for RT3 is here.

I wish I understood the differences which cause the issues reported here… I haven’t seen them on the 3.3.0 release for Win10/11 64-b. Issues I had d/l’ing drivers & f/w (it just didn’t work for me regardless the wait) completely disappeared after the mods to USB processing were incorporated (3.3.0-rc5 I think).

Bruce

I don’t think “clearly not ready” is an objective statement, it’s an opinion on a small sample size. As Bruce said, there are many of us non Aillio folks who have been unable to reproduce this. Nor have the developers reliably. If you can’t reproduce the issue it’s very difficult to investigate and resolve it maybe due to environmental factors not limited to your hardware, os levels and patches , end point protection, other drivers or extensions etc.

It’s very easy to sit on the sidelines and take potshots but who does it benefit ?

Hi Bruce - thanks for clarifying the download location. I am new to Bullet/this community etc. so clearly still learning.

Hello Stuart - I am not on the sidelines and yes, I am sharing my opinion which anyone can disagree with. These issues are real and quite frustrating for those going through it so allow us some leeway in how we go about understanding, processing and resolving it. I am also in touch with Aillio folks on their slack channel so its not as if this thread is in a vacuum.

If there are Aillio folks reading this, it would be great if you could include instructions so that newbies like me can a) extract logs and send it to you guys b) do some debugging ourselves, for those who are technical, such as myself. We have committed to Aillio so our intention is to help to the extent you can enable us.

I have built client/server (and web/cloud) software for over two decades and I find it admirable (and scary) that a company is trying to support as many client-side platforms as Aillio is. QA’ing that many permutations is, to say the least, quite difficult so hopefully I wouldn’t be remiss in saying that the community would like to help.

1 Like

No harm no foul Kash, glad to hear you’re invested in helping get to the Holy Grail of zero issue software. I think there are some folks new to software and the Bullet who don’t appreciate how many factors come into play.

I for one appreciate Aillio even bothering to continue software development for “free” for current owners.

As a software engineer, I loved my “passionate users” so I hear where you are coming from Stuart. Though, newbies who paid thousands of dollars for a machine to then run into basic operational issues could get frustrated when lectured about the complexity of software development when they just need some TLC :slight_smile:

Your last comment is intriguing: could you elaborate? I had wondered why RoasTime existed when Artisan could be an option but I surmise that there are strategic benefits to Aillio in having a community tied to its platform (RoasTime + roast.world).

I have no problem with passionate users. Maybe I’ve had to deal too long with the “toys out of the pram” ones who have no engagement beyond “this software is sh*y and these idiots should do better” :sunglasses:

To my last sentence, once Aillio sell a machine, they really don’t have to spend money on more software development as it impacts the bottom line to an accountants eye. Granted more features could sell more machines so there’s that. You’re right they could have said, go use Artisan but RT uploads some logging to the mother ship so troubleshooting in theory could be easier.

To any I offended I apologize. But telling me check engine light came on fix it, helps nobody.