Problems with Roast World

Something seems to have changed in Roast World.

The Y axis displays are not what I remember them being before and I can’t find any place to change them… The left axis is showing that the temperature range is going from 0 to 1025F degrees (550 degrees if I change it to Celsius )
Am I having a senile moment or did something change?

The profiles don’t look the same when the Y axis is scaled that high. The ROR gets pretty flat.

I tried 3 different Internet browsers. No difference.

Is anyone else seeing this?

I think there’s a might be a double-conversion issue where your graph x, y, and y2 default values were converted. This can explain why the large values are being shown.

You can change this in RT v3 and v4 by going to Config > Graph defaults.

RT is fine. This is only in Roast World.
Your comment about double-conversion is interesting. The configuration for RT is half of what is displayed in RW. (only the Y axis are doubled. X is as configured)

I tried it in metric mode and it was double there also

Does the configuration carry over from Roast Time?
This is my Roast Time config (Version 3.4.1):

You’re right, @billc. This is caused by a fix for an issue in RT v4 and how the chart defaults value are stored. I had updated Roast World to fix an issue RT v4 users experience but didn’t realize the impact it can have on RTv3 users. I will work on getting this fixed and then write back here.

To answer your question, yes, Roast World uses a shared config with RT.

Thanks for reporting.

1 Like

Thank you Derrick,

This is a minor hiccup and doesn’t stop my coffee roasting rabbit hole. LOL