Roast Time doesn't run on Windows 7

Hi, I would like to report that Roast Time doesn’t work properly in Windows 7.

Due to the heat generated by the Bullet, I prefer to use an older laptop next to the roaster that has a completely clean installation of Windows 7, the latest updates and all its drivers. I don’t consider myself a computer novice.

The problem occurs because Windows does not recognize the device and searches for new drivers every time the Bullet is turned on, making it necessary to download, reinstall and reset the drivers and Roast Time each roasting session.

Tried reinstalling Windows 7 and USB drivers again, it didn’t fix the problem. The antivirus was not installed yet.

I have tried multiple versions of Roast Time 3.x and they all give the same error.

I was forced to install new components on the laptop and install windows 10 and works great and stable, but I would like to go back to Windows 7 because the poor laptop is a bit overloaded.

In the Facebook group several have published the same problem with Win 7.


End of life happens in the software industry - Microsoft no longer supports W7 and I don’t think most other vendors would continue to support a deprecated system. If you want to continue using the latest version of RT, then its time for an upgrade, otherwise your option is to stick with the last 2.x release.

This isn’t just a Windows “issue” - in the Mac OS world, there are applications that need to be on more recent hardware/MacOS in order to work. Same solution there, if you want to continue to run legacy hardware, then legacy software is the way.