Roaster Disconnected

Installed RT3 and did the driver update. Restarted my laptop, switched the Bullet off and on. Still says Roaster Disconnected. I had the same problem a few months ago and nothing worked. I saw that the software had recently been updated so I thought I’d give it another go. I’ve uninstalled RT2 too. I really want to use the new IBTS ROR and the other upgrades. RT2 has been mostly working ok for the past few months, with the odd freezing, once while roasting! Please Help!!

FWIW, RT2 and RT3 use the same driver - so you don’t need to do that each time. So RT2 currently works fine for you, but RT3 doesn’t ever see your roaster (and never has), is that correct? Is there anything running that could potentially be blocking RT3 processes from running? I have seen a few people say their AV has been flagging the software.


I have had this happen a couple of times. Usually closing RT window and re-opening does the trick. But last time it happened, I had just done a deep clean on Bullet and the data cable was not connecting properly, fixed by giving the cord a wiggle but have a whiteboard note to check in next session.

1 Like

Ditto here. Had a spare cable. Replaced the old one and it was a go immediately…

I managed to complete a roast yesterday and as I got into charging my second the machine disconnected from my Mac. The machine is functioning fine but just appears on Roast Time as disconnected. I deleted the program and reinstalled it with no luck and also tried using other USB cords and still no luck. Any other tips?

Can you try RT 4 to see if it resolves this issue for you? RoasTime 4 Open Beta and Testing - #2