RoasTime 3.3.2 not loading roast history

Anyone else having this problem where RoasTime 3.3.2 won’t load roast history? It just says"No data available" and “Start roasting to build your history”. I’ve tried logging out and logging back in and deleting RoasTime and reinstalling, but no luck. Any other ideas?

Try this-

  • Log onto and
  • open your dashboard.

Assuming your roasts are listed there you know the files are saved on the server. So now you can…

  • open RT 3.3.2 and assure you’re logged in (you apparently already have confirmed that).
  • Now click the Re-sync button (circled) on the Roast history page:

Re-syncing takes awhile if you have a lot of roasts. The steps above ought to re-load your RT3 roast history in the directories RT3 expects them to be saved.


Thanks Bruce, I’ve been tinkering with it more and I have hit the reload button dozens of times. What I’ve now discovered is that apparently all of the roasts are there, but they just won’t display. Seems to be a software glitch. I’ve found that if you click on one of the sort order buttons, some of the roasts will suddenly appear, though not all. Also if I search for a roast it will come up. Super weird. I just have to go onto Roast World and locate the roast I want and I can then search for it in RoasTime. Who knows

Yes… weird!

Which OS? I’ll leave something for Matt but he’s not likely to see it till Monday.


Thanks! It’s macOS Monterey. It is a MacBook Air with Apple silicon. Maybe that’s related.
The other versions have generally worked fine until now, but this one is being very glitchy with synchronizing and the roast history list.

I’ve had a similar issue in the past and logging out of Roast Time and back in after seems to have forced the resync and showed all my roast properly. Maybe worth a try.

Hey @ranchonagaroastingce ,

That is very odd. Can you try deleting your local files and restarting the app? On mac they would be somewhere around here: /Users/{username}/Library/Application Support/roast-time/

OK, I found that folder and deleted it. I restarted RoasTime and after logging in it displayed a total of 3 roasts. At the bottom it says 158 roasts. When I hit resync, it goes back to showing 0 roasts. Very strange.
Also, this may be unrelated, but when I quit the application it usually asks me twice if I’m sure I want to quit.