Roastime 3.3.2 - Roaster not connected

Finally getting to use my Bullet after having it for 6 months in the box. Plugged it in, it started up fine. Installed Roastime 3.3.2 on my latest Windows 11 machine, and plugged in the USB - Roastime indicates that the roaster is not connected. I tried going through the “install windows driver” steps, but it still says roaster not connected even after a PC reboot and device manager shows a yellow exclamation mark next to Aillio LTD - Bullet R1 Roaster FS and USB Serial Device (COM3).
Please help!

Try deleting the install and then reinstalling roastime. Once it’s installed. power on the pc then plug in the usb before powering on the roaster. If it’s still not going try disconnecting the usb and then connecting again and see what happens. failing that with roastime open, and the roaster connected. switch the roaster off and on again and see what happens. Hope this helps

  • I went to Control Panel → Uninstall Roastime
  • Rebooted PC
  • Installed Roastime 3.3.2 x64 Win
  • Plugged bullet in while roastime is open and USB is plugged in and heard the windows USB connected sound.
  • Roastime still says Roaster not Connected.
    This is all on a fresh Win 11 installation btw.

Is there any way to manually install the USB drivers through device manager?

here’s a couple of locations to get some older versions. Might be worth a try.

for win64

or for win32

or for mac

Got it :slight_smile:
Zadig - USB driver installation made easy (
Zadig updated the driver for the bullet and it’s working with the latest/3.3.2 now.

Hey @coffee_63_c677e13b8 ,

Zadig is the best way if the built in doesn’t work, glad you found it! We are working on getting the automated process working on all machines.


This helped me! Had windows 11 and software couldn’t find my driver. Downloaded Zadig and it automatically installed the driver. didn’t have to reboot or anything. Just worked! Hope this helps others with the setup