RoasTime 3 bug cannot preview and playback roast profiles

There is an issue with the latest version of RoasTime 3 version 3.1.8. I cannot preview and playback roast profiles. Does any one have a solution to this problem?

Thanks a lot,


I did a bunch of roasts yesterday using both playback and overlay on 3.1.8 with no problems.

Any way the preview function in the (new?) … dashboard doesn’t seem to work for me either.

Hello Nicolas,

Thanks for the quick reply. So how do you get access to the playback function without using the preview?



I went through “Roast History” picked a bean and chose “Action” in the top right and then hit “Playback”

Having though about it, I am sure that the “Preview” button worked the first time I tested it out, but nothing there now…

Nicolas under the “Actions” button there is no playback button (see attached picture). Am I missing something :sweat_smile:. Under actions you only have the following choices:

Create recipe


Go to "Roast history) in the menu on the right and choose a roast.
When opened you´ll find another “Actions” menu on the top right corner

Hello Nicolas,

Thank you so much. I’ve solved the problem yesterday, it appears that there is a bug in the new update, when the RoasTime 3 software window is not maximized and all of the options are grouped under the Actions tap the preview window will not work. However, when you maximize the window and all options are visible and not grouped under Actions everything works fine. Also, opening the roast profile and then choosing playback, just like you said, is working as well.

Thanks a lot.



@Nicolas nice looking 800g roast, BTW :slight_smile:

@bradm Thanks

Not sure what the differences are in our OS/RT3 versions but I get Preview to open in a small screen in Win10-64b:

I am not able to replicate this issue either. What OS are guys on? @coffeejug @Nicolas

Hello @mcaillio and @bab,

I am running RoasTime 3 on Windows 10. Yes @bab some roast profiles can be previewed when the window is in minimized state (and all options are grouped under actions), however there are some other profiles that can not be previewed. This could be an issue from Windows 10 or RoasTime 3. I’ll check exactly which version of Windows 10 I am running and I’ll update you soon guys. Thanks a lot




Similar issue as well on macOS Big Sur. Please follow this link for the video.

Can you send me a couple of profiles you are having an issue viewing from RW? This sounds like it may be a data issue with the profiles.

I am using OS10.15.6 (Catalina)

Hello @mcaillio ,

These are some of my roasts: