RoasTime 4.1.2 won't allow edit during or after roast finish

I just updated RoasTime to 4.1.2 to take advantage of the new options in recipes.
After starting off with a playback, I tried to edit the name, and bean info and other things as I have normally done in Version 3.4.1 after I started the playback RoasTime wouldn’t allow me to edit those things.
When I click on the pencil for editing, nothing happens. If I click on the tablet page icon, nothing happens. I can sometimes (but not all the time) close RoasTime by clicking on the x to exit. Sometimes I have to CTRL ALT Delete and force RoasTime to close. Any edits that I had managed to input are gone and I have to go back and edit the roast information from scratch.

I have gone back to Version 3.4.1


works perfekt for me

1 Like

Hmm… I’ve been on 4.1.2 for about 2 (?) months now and seems to be working well for my workflow - which is completely “manual” (i.e. I don’t run recipes, playback or overlay) roasting guided by my hand written plan(s). I also only edit roasts after I’m all done.

Flagging for @mcaillio so he sees this.

Thanks for checking @blacklabs.

I reinstalled 4.1.2 to try again.
I am running Windows 10 with all updates.on a dedicated laptop for the Bullet.
It is a very clean Windows installation.

After installing 4.1.2,
I launched it. 4.1.2 shows up in the upper left corner.
I went to my recipes and selected the latest recipe.
I started the recipe.
Preheat started and I entered information about the roast via the pencil icon.
normally when running a recipe, I can see and track the recipe via the third tab inside the top of the info window. The recipe was missing.
After preheat the drum should have been turning at D6 and the Power should have been P2. The drum was D9 and the power was P7
I ran through the recipe and made manual adjustments throughout to try to get a drinkable roast.

I was able to maybe save it, but I doubt if it will be as good as I wanted. I consider this a loss of 1 pound of good beans.
At the end of the roast, I weighed the roasted beans and tried to enter that information into the roast via the pencil icon for “edit current roast” Nothing happened when I clicked on the pencil, nothing happened when I clicked to the Icon to the right of that. If I clicked on the info button, the Info window would open but still no recipe tab on top.

I had to shut down RoasTime and restart it in order to edit the roast to add the weight of the beans after roasting.
I ran two more roasts trying different thing, but had the same results.

Did you start using it right away after downloading 4.1.2 or did you let it update?
My guess is you were on a very old version of it.

No, it updated immediatly after installing and prompted me to restart, which I did before roasting.

Hey @billc

Could you verify the versions defined in the config? It is under the Software subsection.

Also, 4.1.2 is actually a bit outdated at this point even though that is what a lot of people are on. We will be pushing out 4.3.2 soon if you are interested in trying that.


my current versions are"
Client v1.25.3
Proxy: v1.13.5
Communications: v1.5.1

I unistalled RoasTime.
I went to Bill\AppData and deleted out the RoasTime directories and the Roast-time directory.
Then I ran CrapCleaner (CCleaner) and cleaned the registry.
Then installed RoasTime 4.1.2.
Waited for it to update. Which it did.
Restarted Roastime.
Checke the software versions and everything is the latest.
Rebooted the laptop.
Restarted RoasTime.
Selected a Roast that I wanted to run.
Loaded overlay
Then loaded the same Roast as a Playback
Started the Playback.
I was able to edit the roast name and basic parameters.
The Playback ran to the end with no problems.
During the cooling I put it into Back to Back mode
after cooling I weighed the rosted beans and was able to edit the parameters and enter the roasted bean weight. (which I couldn’t do before)
I started another roast, but the playback turned itself off but left the overlay on.
I manually ran the roast.
after Roasting I was able to enter and edit the parameters .
I re-engaged the Playback and started another roast.
It finished normally and I was able to edit the parameters.

I didn’t try running a recipe.
I am wondering if the last line of my recipe is causing an issue.
The last line of the recipe is an End roast alert.
That line didn’t cause a problem in V3.4
The next time I roast, I will try a recipe and see if the problem is resolved

Hi Billc, did you ever figure out the cause, or did it just start working? I had a slightly similar issue recently, but I could edit, it would just erase, but even though I found a fix, I am still curious about the potential cause, so I can avoid it in the future. It makes me lose a week of analysis. :face_with_monocle: