RoasTime crashed at end of roast and now won't load anything but a white screen {SOLVED}

hey dev team,

i just finished my last roast and as I hit END FC button RoasTime froze on me, and as you can see on my roast history the data it logged is super strange. Anyway, after closing RoasTime now I can’t re-open it and I’m only getting a white screen. I was using 3.4.0, so I updated to 3.4.1 and still the same thing. Deleted and re-installed, re-started my computer…all the obvious things. No dice. Please help!

EDIT: re-installed 3.3.2, still white screen of death. deleted cash folder before re-installing, nadda. Using Mac OS Catalina 10.15.7

Running Terminal in white screened RoasTime reveals this error:

renderer.ts:35 TypeError: Cannot read properties of null (reading ‘collections’)
at Interface. (loki-fs-structured-adapter.js:156)
at Interface.emit (node:events:406)
at Interface.close (node:readline:586)
at ReadStream.onend (node:readline:277)
at ReadStream.emit (node:events:394)
at endReadableNT (node:internal/streams/readable:1343)
at processTicksAndRejections (node:internal/process/task_queues:83)
error @ renderer.ts:35 Failed to load resource: the server

Issue resolved, support was incredibly fast. For anyone else experiencing the white screen of death using RoasTime and Mac OS do this:

  1. Close RoasTime
  2. Make sure you can see “hidden files” in finder (SHIFT+CMD+PERIOD)
  3. Navigate to and delete these two folders:

~/Library/Application Support/RoasTime
~/Library/Application Support/roast-time

  1. Restart RoasTime

BAM. I deleted and re-installed RoasTime before doing this process however it might work without having to do that.