RoasTime on MacOS Catalina?

Has anyone tried running RoasTime on MacOS Catalina 10.15? My computer is nagging me to upgrade but I want to make sure the Bullet will still work with it.

Just got 10.15 installed on my old Macbook Pro (11,3 2014), running RT 2.5. Connects and controls without a problem. I haven’t done a roast yet, just turned the bullet on, connected and ran through the roast stages so I can’t attest to stability during a roast.

The Catalina upgrade was a pain though, just to get it to update.

Our lead coder is also upgrading his Mac to Catalina for testing and recommends people wait until he’s able to take a deeper look at it this week.

1 Like

On my Mac RT will not open at all it just bounces in the tray at the bottom of the screen good thing I roast with a Mac Book

1 Like

I have a copy of RT running on my “upstairs” computer, which is running Catalina, to look over profile data in its more native form. It seems to work fine.

I haven’t yet updated the laptop that’s actually connected to my roaster. Given that RT seems to run by itself on the updated upstairs computer, I suspect the only thing that might go wrong is in the connection to the Bullet itself.

I’m kind of torn–I don’t need to roast for a few days, so I could probably run the upgrade and roll with whatever happens. But, I don’t really use that laptop for anything else so there’s no harm in waiting until there’s more than one other report that all is well.

1 Like

I was able to upgrade and run recipes from RoasTime/Catalina without a problem! The Catalina update is rather lengthy, so I wouldn’t count on a rollback. If you depend on the roaster it might be best to wait it out until the developer on the thread takes a look.

1 Like

I have done 2 roasts and had no problems. The ROR did a little up spike near the end of the second roast but I suspect that was artifact related to the dark roast I was doing rather than a software issue.

Same caveat as others, if you don’t need to upgrade, the safest course is to wait until Aillio blesses it.

1 Like

I am running the current beta 10.15.1 beta 3 with no problems so the current release should be good

1 Like

From what I understand there is some work to be done on RT2 before it is fully compatible with Catalina. That work should be finished very soon (today? tomorrow?) and will be released as a new stable release.

Hi @kafei i was curious if you had any further updates on the new stable release? I just got my Bullet and noticed that i don’t get any live feed when roasting but the results show up after the roast is completed. I was assuming this might be Catalina based.

Hi @kafei
I also got the same problem as @gramma502.
There is no any live feed when roasting (means I can not see any profile) and the profile will come after end of the roasting.
This problem begun since I upgrade to Catalina. THX

Hi guys, I know they are working on it but I am not sure if the new stable will be released this week or the next.

It’s an alpha, but could this be it?


NOT a Catalina-related issue.
I had the issue (no live update of data) when updating from 2.5 to 2.5.5 - and am still on Mac OS 10.14.6

Got the same issue

I have the same issue. I’m on High Sierra. I tried 2.5.5 and 2.5.6. No curves on 2.5.5 and 2.5.6 won’t even recognize the Bullet.

Just checking in if anyone has had any success as of yet?

I’m on MacOS High Sierra and do not get live updates with 2.5.5-beta.

Hey guys,

Happy new year! I was off for a bit, but now getting back into this. Are all of you running on 2.5.5-stable? Apple changed a lot of stuff for us to build our apps on Catalina, so I am not sure if any of that will effect the lower versions. @jeffwizardxd You are on Catalina with the same issue though, right?

Is the issue that when you a roasting, the chart displays nothing? Could one of you make a video of what is happening just to make sure I am understanding everyone correctly?

Appreciate your help!


Is the issue that when you a roasting, the chart displays nothing? Could one of you make a video of what is happening just to make sure I am understanding everyone correctly?

Yes. I’ll make a video for my next roast. I think the problem is the chart has zero height. The quick animation when the UI first appears, where the chart should pop up from the bottom of the screen, I think it just doesn’t pop up.

Another way to play with this bug, do an overlay roast. With an overlay roast, the old roast is visible and the current roast DOES appear on top, BUT the pop-up-from-bottom animation repeats over and over, about once a second, the chart never settles.