RoasTime Software Release Notification

Hello! Is there an option to automatically receive RoasTime software update notifications? I was looking in the Bullet Facebook group and noticed screenshots of RoasTime showing a different look. That made me wonder if there was an update. I had to go to the website to find out there was an updated version. Not sure how long this update has been available.

1 Like


Roastime 3 can be found here: Once this is installed any new updates should be automatic.

Roast World has also been updated. This can be found at



Thanks for the message, however that did not work for me. I installed Roastime 3 quite a while ago and was never notified of the latest update. I had to go to the site today and manually download it.

What version of RT3 did you have installed before the directly d/l’ed update?


And I forgot to ask… which OS are you using?


What OS are you on and which version were you on? The software has autoupdated on MacOS and Windows for some time.


I am on MacOS Big Sur V.11.2.3. Using a 2020 MacBook Pro with the M1 chip. I was on RT V.3.0.80 before I noticed there was an upgrade on the site. It did not auto update. I was seeing the grid layout from people’s screen shots on FB for a while and was wondering why my version didn’t look like that. So that’s when I went to the site and noticed there was a new version.

I believe there were a few RT3 releases without auto-update but I thought 3.0.80 was supposed to have it. No auto-update on Linux systems. My Win10 version auto-updated from 3.1.1 to 3.1.2 (I had manually updated before that by choice).


Thanks for reporting @shawn.c.adkins - 3.0.80 definitely should have auto-updated, not sure why you didn’t get one. I wonder if something isn’t blocking the network requests for you? Let me know if the next version auto-updates for you and if not I can send you over a debug version to get it sorted.


1 Like

Do you know when the next version is coming out? I just noticed another issue…My MacBook froze for some reason and I had to hold down the power button to restart. After re-starting my RoasTime software reverted to 3.0.80 and I could not find the latest version anywhere on my computer. I had to go and re-download the software. I’m also noticing that I cannot log in to the roast world community on Safari. When I click the “community” icon it just refreshes the dashboard and does not take me to the community. Then when I click the “this post” link at the top of my dashboard (it takes me to the community to that link, but I still cannot log in while using Safari. However, Google Chrome works just fine. I am sending this message in Chrome. I am using the MacBook Pro with the M1 processor.

That community issue happened to me too and I notified them of it. They’re looking into it, but what I found that worked is logging out of RoastWorld and then back in and I could get to the community. It’s just a matter of the link it’s referencing. If that doesn’t work and you can still get here, just use, but maybe that’s how you got here in the interim. Anyway, hope that helps.

1 Like

Can we go back to being able to select 50 or 100 roasts at a time please?? And. Can you put a different color on whatever page your are currently on, within all the roast pages please? And the check box on the left doesn’t need to be an inch wide selection that smashes up the name font?

Hello! I see that RT version 3.1.9 is out. I did not get a notification that it was out. I’m still running 3.1.8.

if it does not auto update then you can download it at

Ok thank you. I was asking here because @mcaillio asked me to let him know if the next version does not auto update.

Strange. I will tell him too.

1 Like

When I roasted last weekend RT 3.1.7 gave me a pop-up notification that 3.1.9 is available and whether I wanted to update (which I love having this option!! :clap:t4:) - I held off updating since I didn’t want to mess around with problems given that I needed some more beans for consumption :slight_smile:

@blacklabs You are going to hate this, but that option to update is just for the current session :smile: . When you restart the app it will have installed the new version. We made a design decision to force update due to issues with everyone on different versions. FWIW, 3.1.9 seems to be pretty stable.

Thanks for letting me know @shawn.c.adkins - it definitely seems like something is blocking the request for updates for you. Are you on the RT slack?

No prob! I’m not sure. What is RT Slack?