RoasTime stopped logging data mid-roast


#1

Just did my 8th roast on the Bullet (V2), and the RoasTime software stopped logging data mid-roast…

At around 4 minutes, it stopped receiving/recognizing any data from the machine. I had to continue the roast via the read-outs on the machine.

The software still showed the Bullet as ‘connected’, but the graph no longer charted, and none of the numbers (time, temp, RoR, etc) updated. The software itself didn’t freeze, as I was still able to scrub the graph and use menus and set my markers (Yellowing, FC, FC End) - but the markers just stacked on top of themselves at the end of the cut-off graph. The ‘Operating Mode’ graphic in RoasTime did not advance when I manually went to Cooling either.

I’m attaching a screenshot if it helps. I’m running Win10, 2.5.5-stable, and have performed successful roasts before, so I have no idea why this happened.

Is this a known bug? Any help addressing this would be appreciated.


#2

I haven’t experienced this with RT and I’m really interested in what they have to say!

If you haven’t done it you can open a trouble ticket within RT: click the Messages button then Help Desk and fill in the info. They’ve been at work a few hours already so you may get a quick response.

Bruce


#3

Oh ok - didn’t know there was a reporting feature in RT. Thanks!


#4

I have had several roasts now where I initiated pre-heating and then part of the way through pre-heating the software just froze. A couple of times I didn’t catch it and started roasting which then was a real nuisance because there was no way to interface with the roast time software on my laptop. This is with using the included USB cable, and there is nothing wrong with my relatively new Windows 10 Thinkpad laptop.

Now that I am aware that this can happen, I have found that closing the Roast time software then re-opening it can resolve the issue and then I can roast using it, as long as I don’t charge the machine while the software has crashed and remains crashed. You do have to cycle through the phases of operation, however, to get back to pre-heating.

Kind of a nuisance, sounds similar to the problem you had. I haven’t had the software freeze in the middle of the roast, however.


#5

I wonder if this will work. When I have my similar issue, the software is frozen, and I question whether the “messages” button will work them. Once restarted, I wonder if whatever the fault was would still be evident to whomever would get the message.


#6

If RT Messages doesn’t get you there then you go to aillio.com -> Contact -> Tech Support

Aillio has all the data sent by RT to their server (logs, charts and ??). It’s my understanding some of that data (like the logs) is saved for trouble shooting purposes. They should have everything up to a crash if that’s what happened. My impression was that the data stopped updating the chart which could be a comm issue internal to the Bullet or related to the USB. No idea.

As you’ve seen the charts look a little different than they do on RT, but the image is there though I don’t know if Aillio has a different display than what we see on R.W. I have no idea if a s/w issue will be handled in a similar fashion, but so far the tech has had me try a few things and report back. In this case it seems to be a s/w issue so I don’t know how that will get handled since it can’t be fixed with a simple parts swap.


#7

same here so you aren’t alone in this bug. i’ve also had a couple roasts in the last couple of days not save. when i go to cooling mode, Roast Time goes back to the start roast mode and all my data is gone.


#8

Hey @krmabie,

Unfortunately, this is a known bug, although it seems to only affect a small subset of users. I haven’t been able to pinpoint the cause of it since we have never recreated it over here - but I am hoping RT 3 solves the issue. It is unknown whether the cause was the USB not receiving data or whether the communication between the process that handles USB is disconnected or overflown to the renderer.

@Ken Do you leave the software open (overnight, hours at a time, etc) and it happens after that? Or right after opening? I wonder if when the OS goes into a low power mode if it something happens with the process communication. (USB and UI run on different processes)

In the newest version that is still not released, we made comm changes and also graph/UI lib changes. So I have my fingers crossed it will fix some of these things.


#9

Hey @bill.lyons,

That sounds like a nasty one. I bet the roasts are still somewhere locally - its actually created and updated to as you roast and we soft delete everything. I haven’t heard of this issue before, so appreciate the heads up. Maybe we need an option to recover deleted roasts (even though you didn’t delete them) in case something like this goes awry. This just started happening the past couple days?

Thanks!


#10

Matthew,

Thanks for the quick reply! I recall sporadic issues like this a while back but it seems to have hit me twice in a week now (29 June was the other time). Interestingly, both were quick light roasts. On 29 June, I dropped a roast towards the end of FC and it was lost. Followed up immediately with an SC roast that was saved. Today, I tried to do a similar roast to the one lost on 29 June and it too was lost.

Does Roast Time have an expected minimum roast time? I’m wondering if maybe these small, short roasts are being interpreted somewhere as bad runs and kicked out?

Kind of a bummer because these have been complicated roasts with changes in power to manage ROR and they are lost.


#11

Ah! Yes, we do. I think the min roast time for saving is like 5 minutes in production? I would have to go see what it is set to, but that sounds right. Maybe we should make this an option in the config?


#12

@matthew - Ok, thanks for the info about the bug. I sent my log & debug roast files to Support in my help ticket. The log had a couple entries when the roast froze, but they’re very non-descript, so not sure how useful they’ll be. The roast froze on the two highlighted lines.


#13

Yes, it’s set to 5 minutes. I’d love for this duration to be an option setting :slight_smile:


#14

Me too - would be a great option. I realize roasts shorter than 5min are not that common, but I was doing some quick back-to-back roasts with small volume to test flavor at different drop temps.


#15

I just lost a 22min roast. Went to Cool mode and proceeded to go into my bean catcher stance to coral the stray beans, looked back at Roast Time and everything was gone :frowning: Roast Time says roaster is in cooling mode and gives me the preheat button. Looked on Roast World to see if it might have been captured there but no. Very frustrating as this is a new bean and I just did 700g test and no data. Software stability should be a given, not a bonus.


#16

Hey @bill.lyons,

Sorry about that. If you re-log in, is the roast there? The roast will definitely still live locally on your PC - there is likely some flag that got set that is hiding it. I have been working hard to increase stability in v3.


#17

Yes - found it! Thanks. Logging out of Roast World did cause the ‘lost roast’ to appear as an unnamed roast. Bill


#18

Matthew

I have had this problem on about 10% of my roasts. At first I just switched and then ordered new cords. But that is not the problem.

The problem with exiting and then restarting the software is that the software assumes it is a brand new roast. So if this has happened for example three minutes into roast, it assumes you just charged and are at minute one.

Happy to send you any information to help you duplicate and solve this problem.

Thanks.

Andy