RoasTime upgrade from v2 to v4 does not work [solved]

I upgraded to RoasTime v4.3.2. It simply does not work. v2 worked just fine, every time.

Steps to reproduce:

  1. Hook up roaster to Macbook
  2. Open up RoasTime v4.3.2

Expected results:

  • roaster should show up as connected (often it does not)
  • then when i am able to get it to show up as connected, I should see the realtime graph of roasting as I go

Actual results:

  • most of the time the roaster does not show up as connected
  • when, after repeated disconnecting and reconnecting, it finally shows up, only the PRS button works, but I don’t see the timer count up from 0:00, and I don’t see a live graph of the temperatures

UPDATE: even worse, after downgrading to v2.5.7 (and subsequently v2.0.0), my login no longer works from within the app. I get an infinite spinner when trying to use my credentials, which worked in the new app and work online. Signing up for a new account in the app also results in an infinite spinner. I now have to roast as a guest, with no access to my roast history. I’m just a hobbyist, so this is okay.

@derrick I am sorry to hear of your experience. RT2 was deprecated ~3 years ago and dropped of support last year (I believe an email was sent out on how to upgrade to RT3). That means we took down all resources supporting RT2 (including authentication).

RT 2 and 3/4 use a different authentication system, so you will no longer be able to login to RT2. In RT4, you can “Export Logs” from the Settings->Software section and that should help us solve your issue in regards to your connection woes. Feel free to send them to support or DM me.

Did you try restarting the roaster and application (and computer) when attempting these re-connections? It kinda sounds like something else was claiming the device over USB (were you running another version of RT that wasn’t fulled closed?)

Got it. Re: v2 being deprecated, I only redownloaded it because I thought it was the stable version. It seems pinned to the top of this page: Software - Roast World Community. Perhaps one of the v3 versions should be pinned there.

Next time I roast I’ll try v4 again. Then I’ll export logs if it isn’t working after the restarts.

I’ve redownloaded v4 and it now works. We can close this out. Thanks team!