RoastTime 4.3.2 Destroys Roast Times

For a couple of years I have used the same roast recipe with my Bullet v1.5. And for years the time to roast was around 12 to 12.5 minutes. After upgrading to the latest RoastTime software though (I have always updated software when available) my roast times now take NEARLY 17 MINUTES! And of course they don’t taste nearly as good. Why would updating the software ruin my recipe that I have used for years!?

Anyone else see this issue?


Hey @brandon

It doesn’t look like your recipe is setting the initial settings correctly in the newer versions. I see P6 on the newer profile, but P9 on your recipe start settings. Can you export your logs from Settings->Software section and send them to me?

Not sure where you are seeing P6, I see P9. But I’m hoping it is something this easy to fix because at the moment I can’t roast drinkable espresso. :frowning:

Thanks for the help! (134.5 KB)

@brandon Your recipe is correct, but your recent roasts show a P6 starting temp. Thanks for sending those logs! Definitely something looking off in your recipe execution.


@mcaillio am I correct in assuming this isn’t something I can fix? Or do I need to tweak something?

You can insert a time trigger of lets say 5s for P9. This would solve the problem until we find a fix.

Hey @brandon

You can follow @jacob 's advice. We did find the issue and have a fix going in though, so may be fixed next time you roast.

I’m not sure whether this happened to me or not a few days ago. I often do back to back roasts of using the same profile. The first roast worked fine, but when I did the second for some reason Roastime 4 did not use the prior profile. I saved the roast, but it was much longer than usual. It had reset the preheat and initial power setting (to P6). Now tonight RT 4 told me to restart to update, but it just locks up on a Wait screen.

Do you have Single-use recipes disabled in the configs? Be default your recipe is removed after each roast in RT4.

1 Like

That was it. I had disabled it when I first installed RT 4, but I suspect an update turned it back on.

Launched RoastTime today and updated it…oddly still says it is 4.3.2 although it had me restart “to update”.

Anyway, did two roasts and both of them executed the roast profile correctly so all is well again. Woohoo, thanks @mcaillio and @jacob!

Good to hear! Go to settings, software then you can see the software component’s individual version.