RoastTime Freezing/Disconnecting

For the first 15 roasts, RoasTime was flawless. Since then, I’ve had multiple issues with RT being unable to see the roaster. I’m running the latest RT update (3.2.2). Here are some things I’ve noticed:

  1. RT graph will freeze (in preheat). Roaster will continue working. Closing RT, then unplugging then plugging in the USB and starting up RT again sometimes brings the display graph back.

  2. In (1), often what happens is that it says (a) Roaster disconnected, or (b) Roaster in bootloader (bottom left of screen). At this point, if you click on the “status” it can change the status of the roaster (preheat > roast > cooling etc.) suggesting that it still has some kind of connection to the roaster.

Has anyone had issues with the RT graph freezing mid roast? Or just generally playing up? I’ve tried this on both Windows 10 and Mac OS. Both seem to have similar issues.

So what happened after 15 roasts? Did you move the Bullet, use a different cable, different power outlet? What version were you using for the first 15 roasts?

Things that might help/worth trying:

  1. Unplug / replug the USB and restart RT after you wake up your computer from sleep.
  2. Make sure your Bullet is properly earthed
  3. Try a different USB port
  4. Make sure the cable is intact, or try a different cable

Thanks for the response. Nothing changed that I remember (perhaps playing around with some settings in RT, like the predictive phases, though I can’t quite remember if that was when it started behaving in an adhoc manner). I’ve tried a number of the things you’ve suggested without any success:

  • Tried different cables.
  • Unplug/plugged the USB (there’s only one USB port).
  • Rebooting the PC

What I’ve noticed is that though RT will start out connecting, once it freezes, nothing I do can seem to get RT to reconnect (unplug USB, restart computer etc.)

I’m uncertain how to test that the Bullet is properly earthed. Any ideas on this?

The earthing could be checked with a multimeter. Make sure you are using a 3pin plug all the way to your power socket.
If you are roasting on a laptop you could try running it from battery only.
What computer are you using?

I had an old, spare laptop (very under-powered) that was lying around. Tried using it a couple of months back instead of my usual one and faced similar issues. Moving between the tabs helped in getting rid of the freeze up. This was when RT 3 was just released. As of now, I’m back to my main laptop (not a powerhouse by any counts but better speced) and have not faced any issues so far. The recent updates have made RT so much better, feature wise.

1 Like

What are the specs on your computer? Predictive features are definitely more resource-heavy.

I’m using a Surface Pro 4. I’ve turned off the predictive features at the moment. Have yet to do further testing. I’m pretty sure that the Bullet is grounded correctly.

I used a MacBook (mid 2017) and that seemed to work better. During pre-heat there were a number of times where the USB disconnected, but seemed to reconnect in a second. There was a error message that flashed momentarily.

This happened once during the actual roast. That’s reflected in the attached graph. Any ideas??

Do you have another cable you can try using? Or maybe something needs re-seated on the roaster board. That definitely correlates with a lost USB connection.

I have tried a different cable - that doesn’t seem to make much of a difference.

I tried using the Surface Pro 4 again, that seems to have greater issues. Have used to trying a MacBook Pro (mid 2017) which seems to have better connectivity. What I’ve noticed:

  1. Usually it connects fine the first time (while preheating). It will, during preheat, freeze.
  2. I close RT. Unplug/replug usb cable. Open RT. What I find is that I will get a “roaster in boot loader” - screenshot attached.
  3. After (2) I try again. I close RT. Unplug/replug usb cable. Open RT. Open up, this will bring me back to a more functional screen (graph starts to update again). However, when I dropped the roast, RT didn’t pick up and ended up just pausing (screenshot attached).

Any ideas on how to troubleshoot?


Quick update. I’ve tried using a Mac mini (2012) and that seems to be far more stable. No error messages saying USB disconnecting and I’ve managed to roast twice (separate dates/times) without issues.

Any thoughts? Seems to be a USB issue on my Surface Pro 4 and MacBook Pro?

I had similar issues 3 weeks ago in PLAYBACK mode. I brushed it off, finished my roasts manually & haven’t roasted much in past few weeks. Unfortunately, I did not get any screenshots.
After 3 weeks… I loaded roastime & chose to close & reboot my old Win 7 pc…
Post reboot roastime WOULD NOT LOAD. I UNINSTALLED two versions the current (3 version) & an old (2 version) from windows…
INSTALLED Latest version & had 3 successful roasts yesterday in playback mode…
Seems A-OK now

So this happened to me Today.
It was my first batch of the day and everything seamed alright up to minute 5 when the graph froze, of course I closed and open RT immediately and it work again but froze after 20sec in to it, again closed and open RT also Unplugged the usb and plug again but froze for the 3rd time. I finished my roast manually and on paper, at the end was able to edit the milestones as the graph shows. (I was on overlay).

After finishing my roast, AGAIN unplugged and plug + closed and opened RT and on PH mode it the graph froze, I then restarted my laptop (Windows 10-64bit) twice, until I decided to download the latest stable FIRMWARE from being 584 to 591. Software wise since its been in auto update I have 3.2.3 so there was no update for software, just firmware.

Everything ran smooth afterward, so far finished 5 more batches BUT I did notice the Fan does not go beyond F9, there is no FA-FB and FC, I don’t know if this is something new or I need to calibrate my fan? (before the firmware update I was able to go up to FC).

Plus I got the dead man switch alarm (yes it was on purpose) but the beep sound was different than the usual 3 beeps together. Still don’t know if this is part of the new firmware.

Info: I have the Bullet R1V2, It arrived on January of this year 2021, so it’s a almost 8month old roaster.

The fan speeds are now limited to F9 during roasting and cooling, but available in shutdown mode when you cool your roaster. This is to have enough power for the higher power cooling tray fan. Also, certified bullets cannot run higher than F9 during roasting due to electrical emissions.
The warning messages are different now due to firmware changes.
I don’t know why it would disconnect. Try a different (short) USB cable and keep it away from the main power cord would be worth a shot.

Do you happen to have the firmware 591 release notes? My dead man alarm was weird this time after updating.

Anyone after the update notice the 02 error doesn’t multi beep its just one short beep? I was afraid to hit PRS and it eventually made a loud grunt and cut the power to 0 and the fan to FC… should I have hit PRS? Why shorten the time to hit it, am I the only one who has hit it and accidently ended the roast before